Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991

    2010 RXTX 260: check engine light at full throttle...

    I am getting a check engine light and beep at full throttle. As soon as I let out the light goes away. Anyone ever experience this? No limp mode or code but I didnt keep pushing while the engine light was on.


  2. #2
    NateRXP's Avatar
    Join Date
    May 2013
    Location
    Richmond, TX
    Posts
    746
    +1
    180
    Mine did the same thing. Oil level was too high. Sucked some out and never did it again.

  3. #3
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    I checked two days ago and it was mid level but I will check it again.

  4. #4
    most likely the knock (noise) sensor. very common to fail

  5. #5

    Join Date
    Dec 2013
    Location
    Greece
    Posts
    99
    +1
    11
    Do u use the stock air filter?

  6. #6
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,272
    +1
    476
    How much boost ? I have seen map sensor play up and can be intermittent

  7. #7
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    Quote Originally Posted by OP. LOCK View Post
    Do u use the stock air filter?
    Yes

    Quote Originally Posted by SLASHER View Post
    How much boost ? I have seen map sensor play up and can be intermittent
    stock boost.

  8. #8
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    Quote Originally Posted by phatkewitz1229 View Post
    most likely the knock (noise) sensor. very common to fail
    Seems like I remember this on my 2004 GTX as well. Hmmm.

  9. #9
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    8,399
    +1
    509
    Ecu tuned?

  10. #10
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,272
    +1
    476
    Also seen high oil pressure spike as back off suddenly .. Know of 3 others that have seen this ..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 05-29-2017, 09:59 AM
  2. 65u engine bogs at full throttle
    By Shawnblz in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-21-2016, 05:10 PM
  3. Replies: 5
    Last Post: 06-27-2016, 09:24 AM
  4. 2010 RXT iS 260 - Check Engine Light - Code P060D ??
    By wagoetzmann in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-26-2014, 04:27 PM
  5. New rxtx 260 check engine on first ride
    By Hondaf15x in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-22-2010, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •