Results 1 to 3 of 3

Thread: 94 sl 750

  1. #1

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    220

    94 sl 750

    Is there a throttle cable for oil? My cable only runs the carburator. I assume not but seen the levor with nothing attached


  2. #2

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    220

    Anyone???

    Click image for larger version. 

Name:	GOPR0998.jpg 
Views:	37 
Size:	100.2 KB 
ID:	366471Click image for larger version. 

Name:	GOPR0999.jpg 
Views:	36 
Size:	113.5 KB 
ID:	366470

  3. #3
    aksor's Avatar
    Join Date
    Jun 2015
    Location
    Ottawa, Canada
    Posts
    53
    +1
    1
    Looks like a newer style oil pump from a 95 or later model.

    Mine does not have a linkage attached or the bracket for the linkage on the oil pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SL 750 IDLE rpm 1900
    By quad2water in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-28-2007, 04:11 PM
  2. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM
  3. 94 SL 750 and 97 SLT780
    By quad2water in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 12:41 AM
  4. 94 SL 750 just purchased what should i check?
    By GameDemon in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-19-2007, 12:01 AM
  5. 94 sl 750 maintenance anyone?
    By ducatifreak152 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-09-2007, 03:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •