Results 1 to 6 of 6
  1. #1
    Wakesk8er2's Avatar
    Join Date
    Jul 2010
    Location
    Jacksonville, Florida
    Posts
    46
    +1
    2

    New to me GTX 185

    What's up guys. Long time lurker, first time poster. Got a smoking deal that I could not pass up on this GTX185. This will be my first jet ski project, but I have a bunch of experience with ATV's and minor wrenching on PWC. Previous owner is a good friend of mine and the ski was having trouble and he did not want to mess with it or pay to have it fixed. I'll tell you the saga and my plans. Please feel free to give your two cents. On a side note, there is not much I can do that will put me underwater here, so selling for more powerful ski is not even on my radar.


    The Saga:
    The last time they rode the ski(~2 years), it was going into limp mode giving a high temp code. It would cool off, run for 10 minutes or so, then go into limp mode again. They took it to dealership and they could find nothing wrong. Fast forward to a few weeks ago, he pulls it out and says it sounded like it was not firing on all cylinders, maybe heard some knocking as well, but it was running and firing regardless. Took it up to dealership and they say it needs injectors, an ECU, and that the battery is not charging. They claim that they put a spare ECU and injectors in the ski and it was running ok besides the charging thing. Not sure if they tried injectors with old ECU. They quote him $2000 to do the work and he doesn't want to put the money in it. At this point we make a deal and she has a new home.

    After getting home, I see that the three injectors that were removed in the glove box that have swollen and cracked, presumably due to corrosion. There also looks to be three injectors installed in the ski. I tried to crank it, but battery is a little weak and fuel is very low. I've got the tender on it now and I'll throw a little gas in it tomorrow to see what happens. Lots of paint or powdercoat flaking from SC and head. Will suck what I can out with a shop vac.

    My plans:
    1.) Get it running
    2.) Rebuild SC. What turbine can go in the 185 without destroying motor?
    3.) Riva rear exit. On a side note, can anyone tell me what all baffles will be removed? I feel like half the engine compartment is exhaust baffles.
    4.) X or race style bars with finger throttle. Dad has Yamadog and have come to like the finger throttle.

    Beyond this stuff, I'd like to do forged pistons, valves, etc. To make it bulletproof.


    Click image for larger version. 

Name:	GTX.jpg 
Views:	81 
Size:	143.6 KB 
ID:	366128Click image for larger version. 

Name:	GTX inj.jpg 
Views:	82 
Size:	130.8 KB 
ID:	366129
    Last edited by Wakesk8er2; 07-24-2015 at 10:49 PM. Reason: wrong word changed meaning


  2. #2

    Join Date
    Jul 2012
    Location
    Northern VA
    Posts
    219
    +1
    19
    I have the exact same ski...........If you are willing to throw some bucks into it heres a good build thread........ http://www.greenhulk.net/forums/showthread.php?t=208417

    If theres a knock......That engine may be fubar'd......it can be fixed but you reach a point where its more cost effective to just get a remanned motor from SBT or Seadoo themselves. My TX spun the #2 bearing and it wound up costing me $1650 to get it back in the water.....thats just parts.

    Remember almost all the 4tecs basic long block are all pretty much the same .....185's had cast pistons but size and compression was the same as a 215 255 or 260. Very little of the Core long block has changed in the last 13 years besides the use of better materials.

    Your drive line more resembles an NA setup than an SC setup

    it all depends on your budget

    Those injectors look like they had water in them

    What evidence did they give for needing an ECU?......Thats an expensive part
    Last edited by 4skis; 07-21-2015 at 11:05 PM.

  3. #3
    Wakesk8er2's Avatar
    Join Date
    Jul 2010
    Location
    Jacksonville, Florida
    Posts
    46
    +1
    2
    Started digging and poking around on this thing a little bit...

    The three injectors that are pictured above were what supposedly came out of ski, but there are three injectors installed in the intake. I'm hoping that these are good test units and I won't need to purchase any. The other option is that they just stuck a few bad ones in there to keep what came out from falling apart in the motor.

    i realized it was giving me the red warning light, so I checked the code and it corresponded to MPEM, and then I realized that this was the ECU that the dealer was talking about. Pulled the MPEM and it was full of corrosion. Fuses stuck, broken fuses, a 30 amp fuse in the top left where a 10 amp belongs. I didn't have all the correct fuses, so I'll make a run to the store tomorrow and load up on some fuses and dielectric grease to install after cleaning it up.

    Crossing my fingers that I'll be into this thing a pack of fuses and a few hours of scratching my head.

  4. +1 by:


  5. #4

    Join Date
    Jul 2012
    Location
    Northern VA
    Posts
    219
    +1
    19
    sounds like a project.......just take your time and check everything.......Very first things I would do is compression test and cooling system pressure test.....I usually just use a bicycle pump with a gauge to check for cooling system leaks.......if you hear any knocking dont push your luck......A few extra revolutions could be the difference between a rebuildable engine and a boat anchor

  6. #5
    Wakesk8er2's Avatar
    Join Date
    Jul 2010
    Location
    Jacksonville, Florida
    Posts
    46
    +1
    2
    Cleaned out MPEM and installed all new fuses and she started right up. It is definitely going to need replacing when I come across a good one, but should work for the rest of my diagnosis and repairs. Maybe even a ride or two. Doesn't seem to run rough and I don't hear any knocking. I'll be looking into doing the compression test and cooling system pressure test. Unfortunately, don't have the tools for either test.

    The code that it is throwing now P0562 low battery voltage code. Will probably just pull the battery from my dad's ski and see if that doesn't take care of it.

  7. #6

    Join Date
    Jul 2012
    Location
    Northern VA
    Posts
    219
    +1
    19
    Quote Originally Posted by Wakesk8er2 View Post
    Cleaned out MPEM and installed all new fuses and she started right up. It is definitely going to need replacing when I come across a good one, but should work for the rest of my diagnosis and repairs. Maybe even a ride or two. Doesn't seem to run rough and I don't hear any knocking. I'll be looking into doing the compression test and cooling system pressure test. Unfortunately, don't have the tools for either test.

    The code that it is throwing now P0562 low battery voltage code. Will probably just pull the battery from my dad's ski and see if that doesn't take care of it.
    Use a multimeter and check the battery while its running......should be reading 14v..+/- a few .10ths....if its reading in the 12s or worse its not charging and will die on you while you're riding. At the very least pull your oil filter and check for particles....that doesnt take any special tools

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to me 98 gtx limited
    By Ced in forum 2-Stroke Performance
    Replies: 3
    Last Post: 09-02-2015, 09:04 AM
  2. New to me 2001 GTX. Carb Model. Seized
    By adamwedge in forum 2-Stroke Performance
    Replies: 39
    Last Post: 06-11-2014, 03:18 PM
  3. 03 gtx di - new to me keeps beeping
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-17-2012, 09:46 PM
  4. need help 96 speedster new to me
    By lp*rp in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-26-2007, 07:45 PM
  5. Got new to me Ski
    By Rodneyae in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-18-2007, 05:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •