Results 1 to 10 of 10
  1. #1

    Join Date
    Jul 2015
    Posts
    22
    +1
    1

    Pisser question?

    I have a brand new 2015 kawasaki 15f. Just put my first 3 hours on it. Awesome so far!!!! But when i was flushing the engine after use(used salt away) i noticed no water coming from the side pisser. There was water coming out the back though. I had no problems during the first 3 hours but i also didnt notice if there was or wasnt any pissing water. I will def check it out asap when i get back on it. Should i be concerned and is there anything else i should check. Hopefully it was just due to a weak water flow in the hose if thats even possible!?!?!?


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,782
    +1
    614
    weak water flow and not that important, blow air through it or water if you must, its just an indicator its cooling

  3. +1 by:


  4. #3
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,566
    +1
    623
    When flushing are there any appliances ,washer,dishwasher or other water use like in the bathroom?

    You might have average water pressure in the house, I do ..

    When I flush my ski and very little water coming out ,I run in the house and ask my wife" honey you got the dishwasher of washer downstairs on?"... It's usually the problem when there's little to no real water coming out..

    But hit the the throttle 3-4000 rpms to pressurize the circulation and should start coming out of the pisser a little better..

  5. +1 by:


  6. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,782
    +1
    614
    how does hitting the throttle pressurize the system? there is no water pump..maybe a little exhaust gas creating resistance in the waterbox but thats it.

  7. #5

    Join Date
    Jul 2015
    Posts
    22
    +1
    1
    ok cool. im gonna check tomorrow and make sure that theres water pissing when out on the water. i dock at a private house that runs a hose down to the dock(not my house). i would guess there was low water pressure(not sure about any water appliances running). thanks for the help....

  8. #6
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,566
    +1
    623
    Quote Originally Posted by nicjak View Post
    how does hitting the throttle pressurize the system? there is no water pump..maybe a little exhaust gas creating resistance in the waterbox but thats it.
    How?

    you never gave more gas on the throttle and seen the water come out of the pisser more ??..same amount of water is going thru the flush system but faster..

  9. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,782
    +1
    614
    only because of exhaust gases!! no other reason

  10. +1 by:


  11. #8
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Fort Myers, FL
    Posts
    242
    +1
    71
    Check the pisser end too, my old 300x would get a build up at the tip. Push or sqeeze it a couple times and the water would come flying out.
    Like the other said the pisser is just for show that water is flowing it has no other purpose.

  12. #9
    Speed Junkie UnleashedBeast's Avatar
    Join Date
    May 2007
    Location
    Pensacola, Fl.
    Posts
    758
    +1
    167
    Mine stopped squirting water out hard like before. Used compressed air and good water pressure to clear it. Never had any heat warning on the instrument cluster.

  13. #10

    Join Date
    Jul 2015
    Posts
    22
    +1
    1
    took her out today. no problem on the water. she was pissing fine. it must have been horrible water pressure from the hose while flushing. thanks for all the help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cooling water pilot outlet (pisser) question
    By spastec in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 07-05-2010, 01:16 AM
  2. 08 exhaust pisser question
    By Snoman in forum 4-Tec Performance
    Replies: 17
    Last Post: 04-27-2010, 08:05 PM
  3. pisser questions
    By mbaseball3 in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-04-2009, 04:19 PM
  4. oem pisser question
    By fenn in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-02-2008, 04:40 PM
  5. pisser question
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-10-2007, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •