Results 1 to 2 of 2
  1. #1

    2004 Freedom with corroded electrical box connections

    I just bought a 2004 Freedom that had gotten water into the electrical box. Let me start by sawing that I don't understand electricity very well but I'm trying lol. I've found some of your posts and along with a wiring diagram were very helpful.

    I rewired some connections because the connector board is corroded badly. Now, my question is this. After repairing the wiring I have no power to the cdi. If I hold the bilge button I do get fire to the plugs.

    If I understand correctly, I shouldn't have any power on the yellow wire to the lr module if the engine is not spinning. I have voltage. I unplugged the 8 pin connector to the stator and my yellow wire still has voltage. I believe the lr module is shorted. Am I correct?
    Last edited by K447; 07-19-2015 at 08:31 PM.


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,544
    +1
    2,711
    Quote Originally Posted by greengoblin View Post
    ...

    If I understand correctly, I shouldn't have any power on the yellow wire to the lr module if the engine is not spinning. I have voltage.

    I unplugged the 8 pin connector to the stator and my yellow wire still has voltage. I believe the lr module is shorted. Am I correct?
    The Yellow wires in the electrical box WILL have full battery voltage when the engine is not running. This is normal.

    The Yellow wire voltage becomes AC when the engine is running.

    With the stator connector unplugged the Yellow wires should not have voltage. I suspect you may have soem wires crossed up.

    Can you buy a replacement terminal board and restore the wiring to factory configuration? Much easier to diagnose from afar when the configuration has not been modified.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Genesis i - electrical box connections?
    By malteseowner in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-26-2011, 10:05 PM
  2. FS Advent 1290 with the electric box
    By zx11rider in forum Yamaha Classifieds
    Replies: 21
    Last Post: 07-30-2010, 05:07 PM
  3. FS Advent ECU with the electric box
    By zx11rider in forum Yamaha Classifieds
    Replies: 4
    Last Post: 03-26-2010, 02:25 PM
  4. 02 Freedom Electrical Box Picture
    By VegasRatt in forum Polaris PWC Performance
    Replies: 9
    Last Post: 12-25-2006, 10:50 PM
  5. 2002 Freedom Electrical Box
    By VegasRatt in forum Polaris PWC Performance
    Replies: 4
    Last Post: 10-25-2006, 11:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •