Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    240

    Haveing hard time 94 sl 750

    I finally rebuilt the top end with little to no experience. Compression 131 accross the top. I have trip pump carbs rebuilt 2years ago all lines replaced. There are 2 fuel in lines on my pump, one is pulse from crank, other is main from separator. Does it matter if I switch the two lines? I dont think Im getting fuel to my carbs


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,538
    +1
    2,709
    Pulse connection on the fuel pump must connect to the pulse nipple on the side of the engine. It cannot be swapped with any other hose.

  3. #3
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Pulse line MUST go to center raised connector. Fuel IN has an arrow pointing to the middle. See pic...

    Click image for larger version. 

Name:	Mikuni-triple-fuel-pump.JPG 
Views:	47 
Size:	31.9 KB 
ID:	365945

    Cheers!

  4. #4

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    240
    Ok I had it right the first time but changed it I added a primer ball to try and get the fuel from the tank got it to the separator will switch the hoses back and see what happens with the primer ball. I cranked it with the pulse line off and felt nothing hope I dont need to break this down for a pressure test I am running 1/4 in lines and dont have the tools block off plate etc, etc

  5. #5

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    240
    success with primer pump got it started. Now Im thinking about moving the engine to my 94 slt hull cause I found out this ski 94 sl has been junked. Seems like it would be a pain to register in my name.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SL 750 IDLE rpm 1900
    By quad2water in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-28-2007, 04:11 PM
  2. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM
  3. 94 SL 750 and 97 SLT780
    By quad2water in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 12:41 AM
  4. 94 SL 750 just purchased what should i check?
    By GameDemon in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-19-2007, 12:01 AM
  5. 94 sl 750 maintenance anyone?
    By ducatifreak152 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-09-2007, 03:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •