Results 1 to 6 of 6
  1. #1

    Join Date
    Jun 2015
    Location
    Buffalo, NY
    Posts
    8
    +1
    1

    Lightbulb VX cruiser Performance Issue

    My buddy has a VX cruiser and right now is not able to access internet to post a thread and asked me to do so. He is wondering why his jetski is only going 45 and barely hitting 50 mph, he also said the acceleration is lacking too. Everything seems to be running fine but he cant figure out why he isnt reaching the top speed of 55. Theres nothing covering the intake grate either. I am just as stumped as he is. If any of you have any idea as to why it could be performing sub par please let me know. Thanks in advance! I told him he needs to upgrade and get a high out put like the FZS like i did this summer


  2. #2

    Join Date
    Aug 2014
    Location
    Erie, PA
    Posts
    514
    +1
    71
    Maybe a little on the high side of engine oil in the tank and it sucked some into the air filter. How long since changing spark plugs? Did this happen after Winter storage or running good and then took a dump? What's max rpm? Should be 8,000. My 2012 VX Deluxe is still good with 175 hours but new plugs each year even if they look good and keep the oil in the middle of the low and high mark.

  3. #3
    What year is the ski that you are having the problem with? There could be a multitude of issues that could contribute to the symptoms your describing. 1st thing would be check the compression on the ski and see where its at. Next check the filter for any oil build up like erierunner suggested. A clogged filter can def slow these skis down. See how it does with the filter removed. Also, check the pump to see what the wear ring looks like. If you see more than a slight crack of light coming around the impeller you most likely have excessive gap between impeller and housing. cavitation could explain the loss of acceleration and top end speed. Plugs do go bad and could be part to blame also. Very often its more than one underlying issue with the yama's.

  4. #4

    Join Date
    Jun 2015
    Location
    Buffalo, NY
    Posts
    8
    +1
    1
    I believe his ski is a 2006 with about 100 hours on it. I know he changed the plugs at the end of last season and when we summarized it the plugs were still in good working condition. I'll ask him about the filter and the wear ring and get back to you. Thank you for all your help! I'm still trying to convince him to get a new ski.

  5. #5
    lol people these days....got a 10 year old ski, hasnt done anything other then add gas and wonders why it may be a little slow.....


    Ill give you the magic answer if you promis me he will take care of the ski and not just say "fuck it" that ski is yamis best seller in the world for a reason...


    Old Air filter and ribbon filter clog are 95% his issues....

    R&d filter for the air, and then carb spray for the hockey puck behind the TPS....he will need to remove the throttle body and get access to the ribbon.

  6. #6

    Join Date
    Jun 2015
    Location
    Buffalo, NY
    Posts
    8
    +1
    1
    Quote Originally Posted by kwtony View Post
    lol people these days....got a 10 year old ski, hasnt done anything other then add gas and wonders why it may be a little slow.....


    Ill give you the magic answer if you promis me he will take care of the ski and not just say "fuck it" that ski is yamis best seller in the world for a reason...


    Old Air filter and ribbon filter clog are 95% his issues....

    R&d filter for the air, and then carb spray for the hockey puck behind the TPS....he will need to remove the throttle body and get access to the ribbon.

    Thank you! I will give him that information. I know he bought it used from some guy and has only had it for the past two seasons. So lets give him the benefit of the doubt here. lol But I will ensure he takes care of it and keeps the ski running at its top performance.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2015 VX Cruiser Top Speed issue
    By carbon in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 04-14-2016, 02:22 PM
  2. Yamaha vx cruiser 2008 issues
    By Blondeenz in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 10-08-2014, 04:00 AM
  3. 12 VX Cruiser first oil change issue......wtf?
    By 91e30181 in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 06-23-2013, 02:48 PM
  4. 08 VX Cruiser issue
    By NickG in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 07-06-2012, 08:00 PM
  5. Need help! Battery/security alarm issue on a 2007 VX cruiser
    By jw64wpb in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-23-2011, 01:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •