Results 1 to 6 of 6
  1. #1

    3013 300x Trim problem

    I have been searching and can't find anyone that had a broken trim. My trim box is making a bad grinding noise and the trim is stuck all the way down. I am going to open the box up tomorrow but just checking to see if there is anything I will be able to fix when I open it up. Would appreciate any info from someone who had a similar issue.

    slso, the trim box in the bow keeps coming loose. Anyone have a better way to mount it?

    Thanks


  2. #2
    GZA's Avatar
    Join Date
    Sep 2010
    Location
    New Zealand
    Posts
    432
    +1
    87
    likely has water in it. The speedo wheel cable rubs on the trim cable, causing a hole allowing water intrusion. Pay to check this while you're at it

  3. #3
    Well, I opened up the trim box today and there was no water but the plastic gear case had shattered. Took it to my local shop and they said they have never heard of a trim gear problem. Just my luck. Apparently, you cannot buy parts of the trim system and have to buy the whole box. $750 for the box and components. Almost pays for the extended warranty.

  4. #4
    i would like to buy your old trim box.

  5. #5
    I would like to buy your old trim box. If you cross the straps it will hold tighter.

  6. #6
    Lake Lion
    Join Date
    Jul 2007
    Location
    Dirty Jerzey
    Posts
    1,392
    +1
    258
    Wow. A 1000 years later, and they are still having this problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trim adjustment box flew off under front storage box 3013 300x
    By rod_rod in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 09-01-2015, 12:46 AM
  2. Trim problem 300x
    By argus in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-30-2014, 12:27 PM
  3. 94 SL 750-Trim problem
    By nbpolaris in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-31-2007, 01:56 PM
  4. Trim Problems
    By nu2it in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-25-2007, 09:55 PM
  5. Trim Problem
    By silv2500hd in forum Polaris PWC Performance
    Replies: 3
    Last Post: 05-29-2007, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •