Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2015
    Posts
    3

    Red face Polaris Virage 2001 Sticking at high revs.

    Hello folks I am new to this forum and look forward to hearing from you and reading your posts.

    My problem is: I bought a Polaris Virage 2001 700cc Machine as a project. Has been looked after and is in pretty good shape for its age.

    Had a top end rebuild and a carburettor rebuild but not the accelerator pump which they could not source.

    The engine starts, pretty much on the button (with water cooling attached). However when the revs are increased on the throttle you reach about 4000rpm and the engine continues to increase the RPM even if you release the throttle. So even when the throttle cable is released and retuned to slow speed position the revs remain seriously high, then drop off all of a sudden, sometimes to a tick over speed or an engine stall.


    I do have a replacement accelerator pump on the way part no. 2200732 so was going to fit that and see what difference if any it will make.


    The previous owner said the carburettor had been rebuilt however I am wondering if it has been done properly in light of the mentioned problem.


    Any advice or direction on how to fix it would be appreciated.


    At the moment it will definitely go - trouble is stopping it!!!


    Thanks in advance for any useful advice. (buy a better ski isn`t the type of useful advice I want )

    Regards Pogle.


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,494
    +1
    2,705
    Welcome

    This high RPM sticking is happening in the water or on the trailer?

    Eyeball the throttle shaft at the carburetor. Does the shaft move smoothly and exactly in sync with the movement of the handlebar throttle lever?

  3. #3

    Join Date
    Jul 2015
    Posts
    3
    On the trailer at the moment K447 I haven't got it to the water yet you think it might make a difference when it is under load? I shall check out the shaft movement and make sure it keeps up with the lever movement and is not sticking. I am also hopeful that a new accelerator pump kit will arrive soon from the USA and fit that.

    Thanks once again for your reply much appreciated.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,494
    +1
    2,705
    Quote Originally Posted by pogle63 View Post
    On the trailer at the moment ... I haven't got it to the water yet you think it might make a difference when it is under load? I shall check out the shaft movement and make sure it keeps up with the lever movement and is not sticking.

    I am also hopeful that a new accelerator pump kit will arrive soon from the USA and fit that.

    Thanks once again for your reply much appreciated.
    Who did the carburetor rebuild?

    Was a genuine OEM Keihin Carb rebuilt kit used?

    Where did you source a rebuild kit for the accelerator pump?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris virage 2001
    By keaft in forum Polaris Open Discussion
    Replies: 18
    Last Post: 08-13-2018, 12:53 PM
  2. Polaris virage 2001 1200cc Ficht
    By Gtfotroll in forum Polaris Tech Tips and Info
    Replies: 32
    Last Post: 07-06-2015, 09:20 PM
  3. Rotax 951 stuck at high revs!!!
    By Water in forum 2-Stroke Performance
    Replies: 8
    Last Post: 05-27-2014, 10:28 AM
  4. 2002 Polaris Virage I miss at 6000 rpm??!??!?
    By slednecker2012 in forum Polaris Tech Tips and Info
    Replies: 5
    Last Post: 05-23-2014, 12:16 PM
  5. Polaris Virage 2001 Piston Kit
    By Ferdinand in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 05-06-2009, 07:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •