Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2

    2015 RXPX IBR issues

    I have a 2015 RXPX with a whole 23 hours on it, worked fine when I took it off the trailer, rode it for a half hour and brought it back to the docks to tie up and I have no brake, no reverse no neutral, IBR light flashing and beeping. On vacation this is the first day, dealer can't look at it until Tuesday when the vacation is almost half over by then. Anything I can do myself to take a look at it? I looked around and saw some threads about IBR problems but they all seemed to be 2012 model years.


    Thanks for any help in advance.


  2. #2
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    Double check 30a IBR fuse.

  3. #3
    RGUN's Avatar
    Join Date
    Aug 2013
    Location
    Work: GTA ------------ ----------------- Play: Georgian Bay
    Posts
    551
    +1
    55
    Check battery terminals while you're at it to make sure all your connections are tight.

  4. +1 by:


  5. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    Yes. IBR appears to be very sensitive to correct battery voltage.

  6. +1 by:


  7. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,954
    +1
    1,379
    Look for trash in the linkage.

  8. #6
    dlf2001's Avatar
    Join Date
    Sep 2012
    Location
    High Point, NC
    Posts
    307
    +1
    41
    My ski had one of the zinc anodes come loose and get caught under the ibr bracket.

  9. +1 by:


  10. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,954
    +1
    1,379
    Quote Originally Posted by dlf2001 View Post
    My ski had one of the zinc anodes come loose and get caught under the ibr bracket.
    My Tx did the same thing.

  11. #8
    My ski had one of the zinc anodes come loose and get caught under the ibr bracket too.

  12. #9
    RGUN's Avatar
    Join Date
    Aug 2013
    Location
    Work: GTA ------------ ----------------- Play: Georgian Bay
    Posts
    551
    +1
    55
    .... Which zinc anode should I be checking for tightness before my next time out?

  13. #10

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2
    Fuses and terminals have been checked... What side is the zinc on and exactly where? It's sitting at the dealer now and they can't look at it for a few days. When I tried to do the IBR over ride I couldn't get the bucket to do anything.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 RXPX iBr Module Error
    By saltyqld in forum 4-Tec Performance
    Replies: 29
    Last Post: 05-19-2014, 05:42 PM
  2. RXPX 260 issue
    By steffi69 in forum 4-Tec Performance
    Replies: 23
    Last Post: 09-29-2012, 06:39 AM
  3. rxpx walbro issue
    By ctriverguy in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-24-2010, 10:07 PM
  4. warning 75+ RXPX buck issues
    By rxpstan in forum 4-Tec Performance
    Replies: 94
    Last Post: 07-11-2008, 03:57 PM
  5. RXPX Battery Issue/Question
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-04-2008, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •