Results 1 to 6 of 6
  1. #1

    No more than 5700 WOT

    I have a 2002 GP800R actually 2 of them. The one I am having an issue with runs fine as far as starting, no rough idle actually runs fine until I crack it wide open. Max speed is 50 and the RPM's never get above 5700. I do hear the Power valve motor go on and off out of the water, just had the carbs cleaned and am at loss as to where to start. Compression is good (125/127)plugs look fine and fuel and oil flowing okay. Any ideas?

    thanks,

    Pat


  2. #2
    butterbean_29512's Avatar
    Join Date
    Sep 2013
    Location
    Bennettsville, SC
    Posts
    1,164
    +1
    104
    May need to check PV'S. Remove the covers and check that they move, or that one hasn't dropped.

  3. #3
    Try new plugs and disconnect the power valves and manually turn them open. And see if your top end RPMs improve.

  4. #4
    Have you recently messed with your PV motor? If it isn't rigged correctly it will burn itself out, i know from personal experience.

  5. #5
    Quote Originally Posted by butterbean_29512 View Post
    May need to check PV'S. Remove the covers and check that they move, or that one hasn't dropped.
    I don't have any manuals so really don't understand how the PV works. I do know that all I get when I turn it off is a rotation and activation and then nothing. Also when I hit the throttle no movement of the PV's at all. How are they activated?

    Thanks,

    Pat

  6. #6
    butterbean_29512's Avatar
    Join Date
    Sep 2013
    Location
    Bennettsville, SC
    Posts
    1,164
    +1
    104
    They should cycle once when you shut the ski down, about 3 seconds after shutdown
    They open at about 5000 rpm. Ensure they are adjusted correctly. Also, check the couplers, and make sure they all move

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS PS3 like new. used no more than ten times
    By caliburst in forum General Classifieds
    Replies: 0
    Last Post: 08-18-2011, 05:27 PM
  2. Replies: 4
    Last Post: 06-09-2010, 08:54 PM
  3. No more Green Wheel? If not than.......
    By mstennes in forum 4-Tec Performance
    Replies: 27
    Last Post: 09-27-2009, 09:29 PM
  4. stage 3 kit 04 rxp wont spin no more than 6800 help
    By Extrememotors in forum 4-Tec Performance
    Replies: 26
    Last Post: 05-29-2008, 05:55 AM
  5. No more mods for a while.
    By RXPinMD in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 01-14-2006, 08:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •