Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    May 2013
    Posts
    21

    msx 150 rpm limited to 3250-3500

    unusual limp mode red led and check engine flashing steady in limp mode will reset after several shut down restart cycles and ski runs normal 7250-7400 rpm then just goes back into limp mode anyone have any ideas ?


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,449
    +1
    300
    Rpms when limiting? Edit: never mind, couldn't see the title when reading on my phone. MSX 150, right?
    Last edited by HiPeRcO; 07-15-2015 at 09:58 PM.

  3. #3
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Intermittent 3400 rpm rev limiting... points towards a failing SIFB (module ziptied to wiring harness above the battery, below the main relay). Pretty common electrical item failure on the Weber engines (MSX110/150).

    If your new to the Weber engined MSX 150... check out all the details at link in my sig.

    Cheers!

  4. #4
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,449
    +1
    300
    Does a failing SIFB typically cause a CEL? (Does reverse limit cause a CEL?)

  5. #5
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Quote Originally Posted by HiPeRcO View Post
    Does a failing SIFB typically cause a CEL? (Does reverse limit cause a CEL?)
    Good point... I don't think it does.
    It just tells the ECU reverse is engaged when it's not... so ECU will rev-limit (3400) but no other indicators are triggered.

    So yeah... if this is happening along with a CEL and red light flashing... might not be the SIFB. Hmm...

    Ya know... I'm working on an MSX150 right now that won't rev above 3400-3500 either... and it's not the SIFB... odd.... I'm only triggering an O2 sensor code... so gonna swap that out and see what's next.

    Cheers!

  6. #6
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,449
    +1
    300
    Do you have an aftermarket cross for the O2 sensor? (And please keep us posted on your progress!).

    I have offered to help sidco this weekend if he can't get it sorted out by then...

  7. #7
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,048
    +1
    256
    What does unpluging the O2 sensor do to the rpms?

  8. #8

    Join Date
    May 2013
    Posts
    21
    thanks for the input guys, I brought the ski home today to tinker before I take it to HiPeRcO this weekend to put it on the digital wrench and I tried to do the ETB relearn and I am getting no throttle response after inserting the lanyard and bumping the starter is this because it is stuck in limp mode restricting the throttle body movement ?

  9. #9
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,449
    +1
    300
    Ppu or Etb issue it seems. DW will know

  10. #10
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Hmm... that ain't right. I can't think of any sort of CEL or code that would prevent the ETB from working. So... I'll second a likely PPU or ETB issue. DW should see those codes.

    Cheers!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX 150 rpm limit around 5700
    By rockien in forum MSX/Matrix
    Replies: 51
    Last Post: 11-13-2014, 08:55 AM
  2. MSX 150 RPM Limited
    By 57xray in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-05-2014, 03:00 PM
  3. Replies: 11
    Last Post: 07-13-2011, 07:17 AM
  4. msx 150 problem limited RPM's
    By burton9010 in forum MSX/Matrix
    Replies: 8
    Last Post: 06-10-2010, 08:06 AM
  5. RPM limited to about 4k in the water.
    By CraigC in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-09-2009, 12:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •