Results 1 to 4 of 4
  1. #1

    Join Date
    Jun 2010
    Location
    Central CT
    Posts
    45

    Need my CDI tested--Genesis 1999

    I have a 1999 Genesis carb engine, with a weak spark. With much help from K447 and the spec manual, I have tested the ignition coils, CDI and stator. All meet the spec requirements. The spark is very weak, despite 11+Volts while cranking. It is my understanding the CDI might still need replacement, despite ohm/voltage checks that met the spec. requirements. I was hoping someone would be willing to test my CDI on their engine? I live in CT and would obviously travel to your place for the test. Alternatively, I could ship it to you, but then I would miss the opportunity to meet with another Greenhulk member!

    CDI--P/N 4010377 (no add'l written P/N's)
    Ign coil--P/N 4010174
    Stator--newly purchase from SBT last month

    This entire setup appears to be already have the new ignition upgrade, as it was included with this engine originally. Please see my other posts for additional background, if interested. The summer is flying by and I really would love to get back on the water. I hope to hear from one of you very soon! Thank you in advance.


  2. #2
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    18,081
    +1
    1,609
    Did it have weak spark before putting in the SBT stator? There have been a few rumblings of the non PVL stators doing weird things.

  3. #3

    Join Date
    Jun 2010
    Location
    Central CT
    Posts
    45
    Quote Originally Posted by Mr. Matrix View Post
    Did it have weak spark before putting in the SBT stator? There have been a few rumblings of the non PVL stators doing weird things.
    To answer you question directly, I do not know for sure.

    The engine suddenly died last year, while on the water. Just prior, I was having a strange voltage drain at the time and the engine was not running completely smooth. I didn't have time to investigate the problem until a few months ago. When I pulled the flywheel cover off, I found small bits of metal inside. When I pulled the flywheel itself off, I found the stator had come lose and one of the mounting brackets was broken. The stator bounced around and in-turn knocked-off the small hall-effect magnet attached to the flywheel hub. I installed a new magnet holder on the flywheel 2 weeks ago. A new stator was installed last month. The stator seems to meet ohm/voltage checks correctly. The new magnet holder appears to be triggering the hall effect sensors when I turn the flywheel slowly. I no longer have the strange voltage drain from last year.

    I'm certainly open to trying anything at this point. I'm assuming I have a weak spark, as it is hardly noticable while cranking. The engine sounds great when cranking--just won't start--not even a pop.

  4. #4

    Join Date
    Jun 2010
    Location
    Central CT
    Posts
    45
    Quote Originally Posted by CJC View Post
    I have a 1999 Genesis carb engine, with a weak spark. With much help from K447 and the spec manual, I have tested the ignition coils, CDI and stator. All meet the spec requirements. The spark is very weak, despite 11+Volts while cranking. It is my understanding the CDI might still need replacement, despite ohm/voltage checks that met the spec. requirements. I was hoping someone would be willing to test my CDI on their engine? I live in CT and would obviously travel to your place for the test. Alternatively, I could ship it to you, but then I would miss the opportunity to meet with another Greenhulk member!

    CDI--P/N 4010377 (no add'l written P/N's)
    Ign coil--P/N 4010174
    Stator--newly purchase from SBT last month

    This entire setup appears to be already have the new ignition upgrade, as it was included with this engine originally. Please see my other posts for additional background, if interested. The summer is flying by and I really would love to get back on the water. I hope to hear from one of you very soon! Thank you in advance.
    Bump.

    Looking for someone who can test my CDI on their engine?? I am willing to ship the CDI, if no one is local to Connecticut. Please let me know!
    Thank you in advance.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Needs help with my 2000 Polaris Genesis 1200 fuel injected
    By mchubbs in forum Polaris Open Discussion
    Replies: 16
    Last Post: 08-12-2014, 08:42 AM
  2. WTB Need a cdi and stator for my slx
    By Mack in forum Polaris Classifieds
    Replies: 4
    Last Post: 09-16-2013, 01:59 PM
  3. Replies: 5
    Last Post: 08-07-2012, 12:14 PM
  4. CDI 2001 Genesis 1200 Carburators (need 1)
    By ken evans in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-11-2012, 08:07 AM
  5. Replies: 16
    Last Post: 07-14-2011, 05:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •