Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1

    2008 kawasaki ultra 250x stalls after letting off throttle

    What up
    I got a 2008 kawasaki ultra 250x idle fine when I hit the throttle runs exalent as soon as I let off completely dies . I have replaced tps ,iac spark plugs twice , upgrade pump to 300x specs , new prop ,cleaned out intercooler, checked supercharger belt and pullys, removed gas ,checked for any ehaust leaks, exalent compression on cylinders, new bypass valve, new throttle body, new cable for throttle body to trigger, and its throwing no codes, just ordered new wires and coils .I can't figure out what's going on here so any suggestions would be greatly appreciated


  2. #2
    the wotman likes boobs wotman's Avatar
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    1,069
    +1
    48
    Quote Originally Posted by ghost0511 View Post
    What up
    I got a 2008 kawasaki ultra 250x idle fine when I hit the throttle runs exalent as soon as I let off completely dies . I have replaced tps ,iac spark plugs twice , upgrade pump to 300x specs , new prop ,cleaned out intercooler, checked supercharger belt and pullys, removed gas ,checked for any ehaust leaks, exalent compression on cylinders, new bypass valve, new throttle body, new cable for throttle body to trigger, and its throwing no codes, just ordered new wires and coils .I can't figure out what's going on here so any suggestions would be greatly appreciated
    if you replaced the whole throttle body and didn't fix. Then adjust the idle screw on the throttle body.

  3. #3
    I just double checked screw set exactly at factory spec

  4. #4
    I just double checked screw set exactly at factory spec

  5. #5
    idle air control valve

  6. +1 by:


  7. #6

    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    404
    +1
    63
    I rebuilt a 12F a while back, and it had the same issue after I got it running. Ran fine, but would die as soon as it went to idle. It would Idle fine on the trailer and in the water until you ran it. If you would blip the throttle when it was idling down it would idle for a few seconds and then die. I had a couple boats apart, so I changed every sensor, and the throttle body with no luck. I found that a couple of the valves were out of adjustment. I don't remember if they were tight, or loose, but I re shimmed them and it ran like a champ. I'm not sure how many hours the head had on it, as I pieced it together from a couple different engines, but resetting the valve clearance solved the issue.

  8. #7
    Thanks. Pacer i will give that a shot

  9. #8

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    973
    +1
    159
    Quote Originally Posted by Chris288 View Post
    idle air control valve
    Ok, while on the trailer: Take off the seat, Start the engine then shut it down. If you DON'T hear a grinding/ Servo motor kinda noise after a few seconds of being shut down then order part number 16172-3705.
    If you do hear that sound then your problem is elsewhere, but most likely it's this as it's super common. Also, report back with your findings..


    P/S. If you find you need the above referenced part, also order 92055-3773. The old O-Ring material likes to swell up and it's a pain to get it back in and a waste of time for how cheap a new one is..



  10. #9
    I replaced The idle air control with o ring and at shut down yea it makes the clicking noise . i just got new coils and wires in still no luck having the same problem so im gonna take to shop have it diagnosed and will keep you posted on whats the problem Is. appreciate all the help

  11. +1 by:


  12. #10

    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    404
    +1
    63
    Check the valves. Check the valves. Check the valves. You need a 10MM to pull the cover, and a feeler gauge. I don't know if the 15F and the 250s are the same, but the 15F specs are 0.15mm - 0.24 intake, and 0.22mm - 0.31mm. Pull the plugs, and you can bump the starter to get the cams in the right place to check the clearance.

  13. +1 by:


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 Kawasaki Ultra 250X water still in intake manifold after drowning, help please
    By RickFOB in forum Kawasaki PWC Performance (4-stroke)
    Replies: 34
    Last Post: 07-08-2012, 10:08 PM
  2. JETSKI JUNKIES - Testing 2008 Kawasaki Ultra 250X!!!
    By JETSKI JUNKIES in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 12-12-2010, 01:17 AM
  3. FS 2008 kawasaki ultra 250x super clean
    By SAL08HO in forum Kawasaki Skis
    Replies: 12
    Last Post: 07-12-2010, 07:58 PM
  4. FS 2008 Kawasaki Ultra 250x 4 sale ...MUST READ!!
    By PowerShot in forum Kawasaki Skis
    Replies: 7
    Last Post: 12-11-2009, 01:16 PM
  5. 2008 Kawasaki Ultra 250X Starting Issue
    By RNYE in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-25-2009, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •