Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2015
    Posts
    2

    Could you guys look at these pics - new to jet boats

    Hi,

    I recently purchased a 2004 Sportster 4-tec 155hp boat. I have searched other threads on this board, so if you don't want to answer because these topics have been covered then no problem. I am really just looking for opinions on the pictures I have attached.

    1-I am short about 500-700 rpms it seems, plugs have been done.

    2-I am can only get about 40mph with myself and my skinny wife on board.

    3-I noticed the other day that there is a lot of black caulking around the skid-plate that sits below the jet-pump.

    I have attached some pics, what do you guys think about the impeller and wear ring? (sorry, best pics I could get at the moment) and what do you think about that black caulking? and there also looks like there is black caulking inside the jet pump housing?? ( sorry if I am not using the right terminology)

    Thank you for your time. I appreciate it. Click image for larger version. 

Name:	IMG_3493.jpg 
Views:	91 
Size:	87.7 KB 
ID:	365247Click image for larger version. 

Name:	IMG_3491.JPG 
Views:	77 
Size:	184.6 KB 
ID:	365245Click image for larger version. 

Name:	IMG_3492.JPG 
Views:	87 
Size:	181.5 KB 
ID:	365246Click image for larger version. 

Name:	IMG_3490.JPG 
Views:	84 
Size:	184.2 KB 
ID:	365244Click image for larger version. 

Name:	IMG_3489.JPG 
Views:	93 
Size:	186.9 KB 
ID:	365243


  2. #2
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,354
    +1
    546
    I know on the newer skis the factory uses black silicone to seal the leading edges. Only way to know for sure if the impeller to wear ring is within spec is to use a feeler gauge to measure blade tip clearance. Sorry don't know what the specs are off the top of my head.

  3. #3

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,401
    +1
    222
    It looks like you're drawing air into the pump intake as evidenced by the erosion on the face of the impeller. It looks like someone tried to reseal the ride plate and/or pump shoe and used black silicone.

  4. #4

    Join Date
    Jul 2015
    Posts
    2
    Thanks for the comments

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Take a look at these cylinder pics. Pics of Wossner pistons added .
    By duudu in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 11-18-2013, 04:44 PM
  2. Kinda new guy looking at gp760 stuff
    By pthedude in forum Yamaha Old School Skis
    Replies: 21
    Last Post: 07-25-2011, 05:36 PM
  3. why is my 99 polaris pro 785 blown up? look at these pics
    By xprider02 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 11-23-2010, 07:07 PM
  4. Looking at buying a new ski need advice.
    By Rodneyae in forum Polaris Open Discussion
    Replies: 28
    Last Post: 06-09-2007, 06:17 PM
  5. What vacum are you guys getting at idle?
    By CRS in forum 4-Tec Performance
    Replies: 14
    Last Post: 03-02-2006, 08:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •