Results 1 to 10 of 10
  1. #1

    Join Date
    Jul 2015
    Location
    Lone Star State
    Posts
    44
    +1
    6

    so i spotted something interesting...

    so having never owned jet ski's before (ive been learning alot recently) i just decided to purchase a couple of cheap older ski's with an ultra as one of them by luck. the guy i bought them from pretty much just said you have to mix the oil with the gas in the tank since that is whats required by two stroke. i said ok no problem i can do that. when i go to fill up the first time i noticed there is an oil tank but it was filled with oil and i just made my 50:1 tank mixture and went about my business. i pulled the carbs the other day and saw a bunch of plugs on the bottom of them and made the connection. I dont know if this is right or if its hurting my engine but its in its break in period and the previous owner said to run 40:1 when its off the break in period and i assume im running oil rich. there are lines coming off the oil tank as well and they are all blocked off. im getting worried now since i dont know how the crankcase is getting oil and if i took the life out of the ski after a single trip to the lake. please advise


  2. #2
    wakejunkie's Avatar
    Join Date
    Jan 2012
    Location
    SML, VA and RDU
    Posts
    318
    +1
    19
    Please detail what year and model your ski is so we can help determine if its an issue or not, thanks

  3. #3

    Join Date
    Jul 2015
    Location
    Lone Star State
    Posts
    44
    +1
    6
    sorry, 99 ultra 150

  4. #4
    so are you saying the oil injection lines are plugged but the pump was still on. to premix an ultra150 the correct way you have to split the case and block the check valves that feed from the balance shafts. i would contact the old owner and find out exactly what was done. i purchased an ultra that had the cases check balls welded shut and the oil pump still on. all bearings on the rods are shot, one piston came apart. if that was my ski i would atleast pull that front cover off and verify there is a check valve in there and both balancers are filled with the correct amount of oil

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,747
    +1
    373
    Pre-mix is a really bad idea for Ultra 150s for recreational use. Racers do it, but they periodically pull the engine and change the balancer bearing oil.

    Adding extra oil for break-in is important.

  6. #6

    Join Date
    Jul 2015
    Location
    Lone Star State
    Posts
    44
    +1
    6
    Quote Originally Posted by steve45 View Post
    Pre-mix is a really bad idea for Ultra 150s for recreational use. Racers do it, but they periodically pull the engine and change the balancer bearing oil.

    Adding extra oil for break-in is important.
    i completely agree and i think that was kind of the mentality here. there is a line running lower but there are def. three blockoff on the carbs themselves...

    how are two cycle engine supposed to run with the oil? pulling the motor regularly is def. something i am not interested in doing...

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,747
    +1
    373
    Has the oil pump been removed?

  8. #8
    wakejunkie's Avatar
    Join Date
    Jan 2012
    Location
    SML, VA and RDU
    Posts
    318
    +1
    19
    Sounds like there are 2 lines still remaining that are going to the crank cases but the 3 lines going to the carbs are blocked off for a 50:1 premix. I would pull a case to make sure its getting oil but think this setup is possible to run safely.

  9. #9

    Join Date
    Jul 2015
    Location
    Lone Star State
    Posts
    44
    +1
    6
    Quote Originally Posted by steve45 View Post
    Has the oil pump been removed?
    ill take some pictures when i get a chance. i have no idea how its supposed to be setup or how crankcase oiling works but ill get some pics.

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,747
    +1
    373
    The oil pump is a small, weird looking thing that bolts on the front of the engine with two bolts. It should have 5 hoses coming out that go to the balancer bearings and carbs. It also has a 1/4" hose that goes to the oil tank, and a cable that hooks to the throttle.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Something interesting
    By Chelle in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-30-2015, 04:35 PM
  2. I got something interesting in the mail today
    By Mr. GP1800 in forum Polaris Open Discussion
    Replies: 34
    Last Post: 04-05-2013, 01:11 PM
  3. something interesting
    By skyline2962 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 10-13-2011, 04:58 PM
  4. so something went wrong i
    By 98gsxl951 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 53
    Last Post: 05-24-2011, 10:46 AM
  5. Found something VERY interesting in the pump tunnel.........
    By WATER WOODY in forum Yamaha PWC Performance (2-stroke)
    Replies: 39
    Last Post: 06-12-2006, 08:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •