Page 5 of 5 FirstFirst ... 345
Results 41 to 45 of 45

Thread: Kawi Salt Care

  1. #41
    tomgtv's Avatar
    Join Date
    May 2006
    Location
    Weston Florida (Ft. Lauderdale)
    Posts
    1,744
    +1
    1

    I'll try some too........

    if it works as advertised and explained on the Fluid Film site
    then I'll post results of my ocean running Kawa here.

    BTW - For all you trivia buffs

    Origin of WD40 (WD stands for Water Displacement)
    In early 1950's Rocket Chemical engineers in San Diego were having trouble
    with corosion on their missle motors. One of the engineers created
    WD40 and it worked. It was eventually made into a mas market consumer
    product sold all over the world.
    It was never patented. The reason being they didn't want to give
    up the formula and be exposed to knockoffs 17 years after patent protection wore off. It is company lore that no one knows the formula......except a few principals of the inventor.
    http://www.wd40.com/AboutUs/our_history.html

  2. #42
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,001
    +1
    13
    Use BRP XPS lube, it works great!

  3. #43
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    when i am flushing my ski out the water is not coming out the bypass outlet !!!!!!

  4. #44
    mitch ochoa's Avatar
    Join Date
    May 2006
    Location
    philippine islands, southeast asia
    Posts
    251
    Your ski needs 2.5qts per minute of water near idle speed(1800rpm). If your garden hose pressure is too low and not meet that criteria, water may not come out the bypass outlet. Your engine may overheat if operated for too long.

    If you have enough water pressure, your bypass outlet hose might be clogged with debris..


  5. #45
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    When I'm riding it's ok !! Think I' going to have to check the pressure of the hose.

Page 5 of 5 FirstFirst ... 345

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone ever hear of electronic issues with kawi 1100 in wb1 in salt water
    By emcfetr1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 03-27-2014, 09:00 PM
  2. anyone hear of salt issues related to wb1 with a kawi 1100 ?
    By emcfetr1 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 03-27-2014, 09:59 AM
  3. salt water issues with wb1 kawi 1100 electronics ??
    By emcfetr1 in forum Conversion PWC Performance Skis
    Replies: 0
    Last Post: 03-27-2014, 05:04 AM
  4. Proper salt water protection
    By CRAZEDRXP in forum Sea Doo How To & FAQs
    Replies: 23
    Last Post: 02-07-2010, 06:23 PM
  5. SC KAWI FINALLY GPS'D
    By BDNJ in forum Sea Doo Open Discussion
    Replies: 37
    Last Post: 08-24-2005, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •