Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,142
    +1
    70

    2013 clutch failure

    I replaced my old clutch with the 2013 upgrade. It let go at 51 hours. I expected a lot more use than 51 hours.


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,890
    +1
    282
    Mine went 75 and my 09 went 88......lol

  3. #3
    Slamdcoop0428's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, FL
    Posts
    1,004
    +1
    253
    2013, right at 100hrs with two different wheel upgrades and some good rpm. 8700

  4. #4
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,751
    +1
    875
    Quote Originally Posted by h2jim View Post
    I replaced my old clutch with the 2013 upgrade. It let go at 51 hours. I expected a lot more use than 51 hours.
    Must be that cold Canadian air

  5. #5
    HydroStream6's Avatar
    Join Date
    Jun 2012
    Location
    New York
    Posts
    671
    +1
    94
    Mine let go at 41 hours. Put a 2014 in and upgraded to the Superclutch as well.

  6. #6
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,142
    +1
    70
    Does the 2014 work better than the 2013?

  7. #7
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    599
    I got 6 outta my 2013 clutch......... I've seen them go bad as soon as 10 minutes....... 51 isn't soo bad after all


  8. #8
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,142
    +1
    70
    It's a shit job with the motor in. Especially in a conversion. I hope I get way more out of this one.

  9. #9
    HydroStream6's Avatar
    Join Date
    Jun 2012
    Location
    New York
    Posts
    671
    +1
    94
    I've heard varied reports on the 14 vs 13... not sure what the consensus is. I used it because I got it for cheap.

  10. #10

    Join Date
    May 2012
    Location
    sunny coast qld
    Posts
    68
    +1
    1
    Do you guys have bovs? I have 158hrs on factory clutch and still going, had a bov on since day one, my ski is not babyed eather?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 clutch any failures?
    By WVGP1200R in forum Yamaha PWC Performance (4-stroke)
    Replies: 152
    Last Post: 03-10-2014, 04:51 AM
  2. Supercharger Clutch Failure
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 52
    Last Post: 02-06-2006, 07:38 AM
  3. S/C Clutch Failure.
    By Big Red Monster in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2005, 08:22 PM
  4. SC Clutch Failure Sreen?
    By RXDI2 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2005, 12:14 PM
  5. Pics of S.C. Gear after clutch failure
    By two2curupt in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-10-2005, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •