Results 1 to 6 of 6
  1. #1

    I need to repair my Stinger exhuast

    I have two issues with my exhaust.

    #1, there is a bolt missing on the Stinger, the hole in the mounting tab is about 2-3" directly above a head bolt. at first glance a 2-3" longer head bolt with some kind of sleeve to take up the extra space between the Stinger and R&D head could solve the issue, but I wonder if some sort of bracket wouldn't be a better option. I'm not sure how a 2-3" sleeve/spacer would affect head bolt torque

    #2 I got a rip in one of the silicone couplers (I used a ton of RTV silicone and 3' of duct tape to temporarily stop it from leaking water onto the the air filters)

    It looks like just a nice quality 3" silicone coupler, will any 3" coupler work, most silicone couplers are rated to around 400deg, how hot does the exhaust get? there is water injected into the system, I just want to make sure.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	GOPR0005.jpg 
Views:	49 
Size:	96.7 KB 
ID:	365022  


  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,544
    +1
    194
    one fast way to fix it , get the oem pipe , there's not gain using that pipe.

  3. #3
    Getting a stocker back in there will actually get you some gains.

  4. #4
    I'm happy with the performance, I'll run right next to a 2013 Kawasaki Ultra300 (with a hand full of Riva parts on it) Is the stinger really that bad? Even if i have every intention of keeping this Waverunner for a while and when the current 1200cc engine is spent I'll go 1300cc, 1390cc or more on the displacement. I'll probably never spend triple money

  5. #5
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,544
    +1
    194
    it's not like its a bad thing to have , it's more like if it gets damage is cheaper to replace with the oem .

  6. #6

    Join Date
    Jun 2015
    Location
    Kingfisher, OK
    Posts
    89
    A piece of silicone hose should work fine. Can you not just drill a hole in the flange to use the stock exhaust mount? It looks like it is right over the far back one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Who here is innovative? - Need to repair a polyethylene hull
    By Shibby1485 in forum Open Discussion
    Replies: 5
    Last Post: 09-19-2007, 11:25 PM
  2. Replies: 3
    Last Post: 05-29-2007, 02:06 PM
  3. I need to get my RPM's up-Any ideas.
    By Mongoose in forum Yamaha Old School Skis
    Replies: 28
    Last Post: 04-27-2007, 05:12 PM
  4. need to change my e-mail address here
    By texas swede in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 02-10-2006, 09:44 AM
  5. Do i need to cahnge my wear ring?
    By Totallyblown in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-21-2005, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •