Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: v teck

  1. #1

    v teck

    just reprogram my ecu on my rxtx with the Vtech 8350 and took it out today. I hit a 76.15 and a 76.59 turing 8260-8280 at 3/4 tank of fuel I believe with a little tuning and less fuel she'll hit 77...


  2. #2

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27
    I need to get some mods i guess to see what the tune can do.

  3. #3

    Join Date
    Mar 2013
    Location
    Appleton, WI
    Posts
    590
    +1
    93
    Quote Originally Posted by superjetpilot View Post
    I need to get some mods i guess to see what the tune can do.
    Start with the intake. The factory is very restrictive. Then do the Riva manifold upgrade. Those two mods should bring up your RPM's about 150-200 and help boost all for about $500ish. Then update the prop.

  4. #4

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27
    Ok I'll start with those mods and see.

  5. #5
    I took the rxtx out today ran her down to 3 bars of fuel and started some speed runs the 3 best were 77.46, 77.77 and 77.93 thought I was going to get a 78+ but on my last run the ibs went out. no reverse, brakes and stuck in limp mode. I had 3 hrs on this v tech tune is there a problem going on with the v tech tune this make the 2nd ski with this tune on a 2010 rxtx I know of having this same problem. now I did have some ibs problem before the v tech tune but I though they were fixed when the dealer did up grades early this summer. it ran good un till until this.
    Last edited by yellow jacket; 07-12-2015 at 10:07 PM.

  6. #6
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,642
    +1
    506
    you can blame a lot on a vtech tune
    but ibr module problems are usually brp's fault

  7. #7
    I hope its a brp problem I really like the tune the ski will read ibs module something on the dash when I start it up guess its a research week this week any help the bucket is in the up position when it turn off it should b in the natural position.

  8. #8
    Titan_Joe's Avatar
    Join Date
    Jan 2015
    Location
    Pottstown PA
    Posts
    853
    +1
    176
    You probably have something jamming up the bucket, carefully take a look around at everything to make sure nothing is hidden in the bucket area. A very small rock/stick could be the culprit

  9. #9
    will take a look it tries to move but then stops

  10. #10
    yep that was the problem something cough in the reverse bucket and knock it off track...now back to try to brake that 78 mph barrier but its a solid 77 mph machine..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD V-Teck
    By carlosdelgado in forum Sea Doo Classifieds
    Replies: 14
    Last Post: 08-01-2015, 12:25 PM
  2. 4 teck oil
    By coopersst in forum 4-Tec Performance
    Replies: 13
    Last Post: 02-24-2010, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •