Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Robbe144's Avatar
    Join Date
    Mar 2014
    Location
    Sweden
    Posts
    50

    Gp1200r not charging bad lightning coil

    Hi
    I have a problem with my gpr, it's not charging.
    Measured lightning coil resistance 0,25 ohms, replace stator? That's what my reading tells me.
    Rectifier/regulator no volts when cranking. Likely from the bad lightning coil
    Pickup coil working, the ski starts and runs.

    If I have to replace the stator I would like to do that this winter. Can run the ski like this and charge after every run? How much time can I expect from a fairly good 19 ah battery?

    /Robert


  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,541
    +1
    194
    try the rectifier first , its easier to replace and mostly the cause of no charging.

  3. #3
    Robbe144's Avatar
    Join Date
    Mar 2014
    Location
    Sweden
    Posts
    50
    Yes I hoped for that when I started measuring.
    There are no volts on the red-black or green-green . I belive G-G is from lightning coil to rectifier.

  4. #4
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,541
    +1
    194
    Quote Originally Posted by Robbe144 View Post
    Yes I hoped for that when I started measuring.
    There are no volts on the red-black or green-green . I belive G-G is from lightning coil to rectifier.
    you can get a rectifier for few cents , out of 10 , 9 is just the rectifier.

  5. #5
    Robbe144's Avatar
    Join Date
    Mar 2014
    Location
    Sweden
    Posts
    50
    Ok you're right about that.
    I'll replace it.
    Any recommendations where to buy?

  6. #6
    Robbe144's Avatar
    Join Date
    Mar 2014
    Location
    Sweden
    Posts
    50
    Hi
    Replaced rectifier still not charging.
    It's getting harder to start also. Now it only starts with a fully charged battery. Don't want to make things worse..

    Any suggestions? Stator?

  7. #7
    Robbe144's Avatar
    Join Date
    Mar 2014
    Location
    Sweden
    Posts
    50
    Hi
    Can also add that the spark seems weaker than before.
    It always had a good visible strong spark.
    Now it's weak when the battery comes down a little. When at ~12,4V no spark at all.

  8. #8
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,541
    +1
    194
    did you swap the ecu with the one i send you? also are you 100% sure all the wires got connected right ?
    Last edited by mikegp; 08-17-2015 at 07:16 PM.

  9. #9
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,541
    +1
    194
    actually my bad i do have a stator from a 1200r i just start to part out.

  10. #10
    Robbe144's Avatar
    Join Date
    Mar 2014
    Location
    Sweden
    Posts
    50
    Hey man
    No swap on the ECU yet. I have a triple piper with Advent ECU. I'm not sure if it's" bolt on" eventually need to bridge some connectors right?

    Think I'm on the right path changing stator when it acts like this?

    As for connections, looks like you can only set up the rectifier one way and I put them in place real good but of course things can happen.
    Last edited by Robbe144; 08-18-2015 at 02:12 AM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp1200r not charging
    By greene in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 09-29-2010, 05:10 PM
  2. Most Possible Cause??? not charging battery GP1200R
    By chris1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-09-2009, 10:34 PM
  3. 04 rxp not charging
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-26-2007, 07:33 PM
  4. Not too bad of a day at the lake......
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-23-2007, 11:28 AM
  5. OO yeah....Hopefully its not too bad!
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 06-03-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •