Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991

    2010 RXTX 260 - VTS not working

    The IBR works fine and the VTS gauge works but nozzle will not trim up and down. Anyone with suggestions? Is there a seperate control module for the VTS on the 2010+ RXTX 260's?
    Last edited by Ski Hacks MG; 07-09-2015 at 08:05 PM.


  2. #2
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    Bueller?

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,644
    +1
    506
    if you have ibr you dont have vts
    the ibr module does all the bucket/nozzle moments
    brake, neutral and trim

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    Then why do I have VTS buttons as well as VTS modes?

  5. #5
    Titan_Joe's Avatar
    Join Date
    Jan 2015
    Location
    Pottstown PA
    Posts
    853
    +1
    176
    Quote Originally Posted by CCW View Post
    Then why do I have VTS buttons as well as VTS modes?
    The VTS is built into the IBR module. I had issues with my trim and the IBR module had to be replaced $1300.00

  6. #6
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    Any suggestions?

  7. #7
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,644
    +1
    506
    use the ibr override and watch the unit work
    see if its binding or other

  8. #8
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    Already went through override test. IBR functions perfectly. Trim does not.

  9. #9
    Titan_Joe's Avatar
    Join Date
    Jan 2015
    Location
    Pottstown PA
    Posts
    853
    +1
    176
    Maybe the VTS motor is bad, I know the older seadoo's used a off the shelf car power window motor for the trim . I wonder if that is still the case?

  10. #10
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    I am told there is no motor on the IBR skis.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VTS Not working help
    By CarFanatic in forum 4-Tec Performance
    Replies: 20
    Last Post: 07-02-2008, 09:26 PM
  2. RXTX VTS Not working
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-27-2008, 11:01 AM
  3. Vts not working
    By eclipsecleaning in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-10-2007, 07:32 AM
  4. VTS not working
    By North49 in forum 4-Tec Performance
    Replies: 19
    Last Post: 06-11-2007, 08:06 PM
  5. VTS Not Working
    By Tas_RXP in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 03-29-2006, 05:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •