Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    10

    I just picked up 1997 sl900

    Now I have three sl model. The polaris is complete was told good engine but she act like isnt getting power.
    If im correct the red engine may need updated cdi. How do i checked if mine need updated or already updated?


  2. #2
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,415
    +1
    1,476
    Open the electric box and look at the part number on the CDI. 4010447 is the updated CDI. It may have the number 4010885 on it as well. Anything that starts with 406 is not updated.

  3. #3
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    10
    Quote Originally Posted by Mr. Matrix View Post
    Open the electric box and look at the part number on the CDI. 4010447 is the updated CDI. It may have the number 4010885 on it as well. Anything that starts with 406 is not updated.
    I looked up its start with 406 so I think I found the problem... Beside a fuel lines will need updated and carb cleaned out from saint not in use for 5 years. U have a spare updated Cdi laying around any chance?

  4. #4
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,415
    +1
    1,476
    No spares I am willing to part with. You will need the whole update kit, stator and CDI. I think Martos sells the kits with Polaris stators, not aftermarket for the same price as the SBT ones.

  5. #5
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    10
    Omg a 600 dollar for just a updated system no wonder the owner got rid of it...
    the wiring to cdi box isnt looks right several wiring has been disconnect and rigged out... anybody has a "blue print" so i can straight it out. Right now no power wont turn over at all and the display doesn't turn on i believe there disconect wiring somewhere.

  6. #6
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    10
    Other than that she looking good for its age... u know what I am thinking about pull engine out and sell it then buy a 1200cc engine from genesis that i saw good running for 800 no title. A 1200cc in small sl hull?


  7. #7
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,415
    +1
    1,476
    Try and get a better picture of the inside of that electric box. Im sure one of us will see something.

  8. #8
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,214
    +1
    1,720
    Quote Originally Posted by Seakid View Post
    ... I am thinking about pull engine out and sell it then buy a 1200cc engine from genesis that i saw good running for 800 no title. A 1200cc in small SL hull. ...
    I did just that a couple of years ago. 1997 SL900 swapped in a red 1200 engine. Ran nicely but needed a lower angle nozzle wedge in the jet pump to reduce porpoising at speed.

    I posted some details of the engine swap at the time, somewhere on here.
    Last edited by K447; 07-12-2015 at 10:41 PM.

  9. #9
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    10
    Quote Originally Posted by K447 View Post
    Quote Originally Posted by Seakid View Post
    ... I am thinking about pull engine out and sell it then buy a 1200cc engine from genesis that i saw good running for 800 no title. A 1200cc in small SL hull. ...
    I did just that a couple of years ago. 1997 SL900 swapped in a red 1200 engine. Ran nicely but needed a lower angle nozzle wedge in the jet pump to reduce proposing at speed.

    I posted some details of the engine swap at the time, somewhere on here.
    Can u post link? Id like to see that.

  10. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,214
    +1
    1,720
    Quote Originally Posted by Seakid View Post
    Quote Originally Posted by K447 View Post
    Quote Originally Posted by Seakid View Post
    ... I am thinking about pull engine out and sell it then buy a 1200cc engine from genesis that i saw good running for 800 no title. A 1200cc in small SL hull. ...
    I did just that a couple of years ago. 1997 SL900 swapped in a red 1200 engine. Ran nicely but needed a lower angle nozzle wedge in the jet pump to reduce proposing at speed.

    I posted some details of the engine swap at the time, somewhere on here.
    Can u post link? Id like to see that.
    I might not have posted an actual project thread, just a few posts as things were being discussed.

    http://www.greenhulk.net/forums/show...=1#post2019823

    http://www.greenhulk.net/forums/show...=1#post2273488

    http://www.greenhulk.net/forums/show...=1#post2100643

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just picked up a 1997 Yamaha Exciter 220
    By ADAMBOMB in forum Yamaha Sport Boat
    Replies: 3
    Last Post: 04-05-2010, 02:25 PM
  2. Just picked up a 1996 speedster
    By Kragar in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 02-17-2008, 06:35 AM
  3. Just picked up a 95 xp (720)
    By ADAMBOMB in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-29-2007, 09:33 PM
  4. just picked up my ultra 250
    By GDM in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 04-30-2007, 09:57 PM
  5. Just Picked up my '06 RXP
    By ramnj in forum Sea Doo Open Discussion
    Replies: 32
    Last Post: 04-08-2006, 05:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •