Results 1 to 2 of 2
  1. #1

    96 slt780 craped out again

    Had the jetskis out over the holiday weekend, I always start them on the trailer prior to putting them in the water, it started right up and ran great, I put it in the water 20min later and won't rev up, starts good and will idle all day.., I got it home and ohmed the new stator and the blue/red to red/white ohms at 26-28 ohms, specs is 90, I have all sensor wires unplugged..


  2. #2
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    895
    +1
    21
    Compression is OK on all 3 cylinders?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Parting out '95 Polaris SLT750 & '96 slt780 complete
    By cubsfan2516 in forum Polaris Classifieds
    Replies: 14
    Last Post: 05-17-2009, 12:36 PM
  2. 96 slt780 having problems.
    By twometal in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-11-2007, 06:29 PM
  3. Probablem with buddys Ski, cutting out again.
    By zdowell in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-01-2007, 05:07 PM
  4. Correct plug and what does the idle set at on a 96 slt780
    By gvnitup in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-06-2007, 10:16 AM
  5. 96 SLT780 general questions
    By r8333b in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-19-2007, 11:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •