Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    twokexlv6coupe's Avatar
    Join Date
    Jul 2011
    Location
    north jerz
    Posts
    573
    +1
    54

    Still missing 300rpm

    Ski- 2007 RXT, 163hrs

    "Problem"- I've never once seen over 7800rpm's, even in the best conditions, over the past 3 years. This past sat was 70* air, 75* water pretty calm for instance, still 7800.
    I'm not looking for an 85mph RXT, just wanna make sure she's running 100%. Hell I hardly even care about mph.
    Even when she was 100% stock, never saw over 7800.

    (Relevant) Mods - DIY intake (attached an extra air filter directly to SC), DIY exhaust resonator removal, OPAS removal, ET127 and #42's both with around 30hrs on them. I don't know the slip in the SC'r cuz I have no way of keeping the motor or SC locked (other than clamping a vice grip around the driveshaft haha), but I DO have a ft-lb torque wrench.
    Also have a new (15hrs) OEM wear ring and R&D pump seal. Clearance of WR-prop is .010" on two blades, .008" in the other 2 (max spec is .014"), and even tho it does look like I sorta tweaked the seal on install, considering I had the problem prior to install I don't think it's WR or seal.

    The pic of the dipstick is on a cold engine, so there's no way oil is overfilled.

    All 4 trailing edges look as pictured- almost razor sharp.

    And even tho there's ZERO cavitation, I feel she should pull harder from a dig. Any idea what it could be?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	uploadfromtaptalk1436232413470.jpg 
Views:	107 
Size:	52.2 KB 
ID:	364542   Click image for larger version. 

Name:	uploadfromtaptalk1436232380830.jpg 
Views:	108 
Size:	81.1 KB 
ID:	364541   Click image for larger version. 

Name:	uploadfromtaptalk1436232364123.jpg 
Views:	115 
Size:	51.9 KB 
ID:	364540   Click image for larger version. 

Name:	uploadfromtaptalk1436232350990.jpg 
Views:	129 
Size:	46.8 KB 
ID:	364539  


  2. #2
    twokexlv6coupe's Avatar
    Join Date
    Jul 2011
    Location
    north jerz
    Posts
    573
    +1
    54
    Anyone got any ideas? I gotta new pump seal on the way, but I don't think that's the prob.

    I'll check the carbon seal for any carbon soot/build-up, but considering I never notice excessive water in the hull after riding/spraying water while riding, I think that's in good condition too.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,953
    +1
    1,379
    ET127 & 42's without an extrernal IC you might be rich. Did you buy it new?

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,453
    +1
    182
    Is your throttle plate opening all the way to the stop, when u push the throttle lever all the way ?

  5. #5
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,510
    +1
    234
    Ditch the 3 inch intake add a 4 inch intake problem fixed

  6. +1 by:


  7. #6
    Scotty's Avatar
    Join Date
    Mar 2007
    Location
    Cropwell,Al
    Posts
    321
    +1
    6
    Quote Originally Posted by psycho rxp View Post
    Is your throttle plate opening all the way to the stop, when u push the throttle lever all the way ?
    I bought the 07 GTX I have new. After having it about a year I noticed a lot of slack in the cable at the throttle body. it was getting about 3/4 throttle. Made a big difference after adjustment. Cable housing nuts were not loose so it was assembled like that.

  8. +1 by:


  9. #7

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    348
    +1
    33
    What is your compression ?

  10. #8
    twokexlv6coupe's Avatar
    Join Date
    Jul 2011
    Location
    north jerz
    Posts
    573
    +1
    54
    All good suggestions, thanks guys!


    Quote Originally Posted by troyheb View Post
    ET127 & 42's without an extrernal IC you might be rich. Did you buy it new?
    I got the ski about 3yrs ago w/ around 125hrs on it, then the 127 and 42's were shortly after that.



    Quote Originally Posted by psycho rxp View Post
    Is your throttle plate opening all the way to the stop, when u push the throttle lever all the way ?
    Just checked this. There's a tiny amount of travel left @ WOT on the throttle plate, maybe 1/8". Will def tighten that up, hopefully it's something that easy!


    Quote Originally Posted by bluestram View Post
    What is your compression ?
    Will also do soon, it's easy enough. Is there a common problematic cylinder on the 4tecs? I know my old Kawi #1 always ran the hottest, and my subby #4 hottest.

  11. #9
    twokexlv6coupe's Avatar
    Join Date
    Jul 2011
    Location
    north jerz
    Posts
    573
    +1
    54
    Quote Originally Posted by twokexlv6coupe View Post


    Quote Originally Posted by bluestram View Post
    What is your compression ?
    Will also do soon, it's easy enough. Is there a common problematic cylinder on the 4tecs? I know my old Kawi #1 always ran the hottest, and my subby #4 hottest.
    Of course I shoulda known better than to jinx myself and think of it as a "seemingly easy task"

    Turns out my compression tester doesn't have the right size spark plug adaptor. How does everyone else fit a compression tester?

  12. #10
    take 1-2 mm out of the prop

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this missing piece in this exhaust manifold still good
    By mlgarner in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-20-2015, 03:55 PM
  2. 96 GSX still missing rpms......
    By steelers87 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-02-2010, 09:04 PM
  3. help , where are my missing 300rpm ??
    By gzk in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-01-2009, 05:10 PM
  4. notice anything missing!!??
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-17-2005, 09:48 PM
  5. RXP still in the shop
    By Jrsrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-10-2005, 09:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •