Results 1 to 2 of 2
  1. #1

    Question After towing with 2009 FX HO problem

    I recently pulled a tube around the lake on my 2009 FX HO, afterwards, my waverunner would take about 20 seconds to finally acting normal again. What I was experiencing was high RPM's but no acceleration when trying to take off (remember, this is without pulling anything). After about the 20 seconds of high RPM, it would finally act like normal. Is this normal for the ski?


  2. #2
    no, one time deal or us it still happening? If it just happened once you probably and something stuck in the pump area, i.e. a bag sea weed etc... Was it vibrating bad too?

  3. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 07-15-2014, 05:21 AM
  2. Replies: 1
    Last Post: 07-13-2014, 06:14 PM
  3. 4-Stroke 2009 FX HO Engine Compression problems
    By tat221 in forum Yamaha Projects & Build Threads
    Replies: 3
    Last Post: 05-03-2014, 08:37 PM
  4. Having throttle problems with my fx ho.
    By ljshaun in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-16-2011, 06:00 PM
  5. FX HO problems
    By BluntForceDrama in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-14-2008, 05:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •