Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    220
    +1
    2

    Pump support AGAIN

    Why would my jet pump seal keep twisting on the pump and breaking my support. Bolts were all there.


  2. #2
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    220
    +1
    2
    This piece of shit is starting to piss me off 2011 RXT-X .

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,024
    +1
    780
    Has the engine to pump alignment ever been checked?

    If not, it CAN cause PTO seal failures, vibration, premature wear ring use and carbon ring use, spline failures, and pump issues.

  4. #4
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    220
    +1
    2
    Jim said he aligned it. I have no idea but I do know I am getting tired of the same problem

  5. #5
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    220
    +1
    2
    First ride out after replacing the support and 30 mins time I was swimming my ski back to the dock

  6. #6
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    220
    +1
    2
    Feel like going over to the other side

  7. #7
    Pete1027's Avatar
    Join Date
    Jul 2012
    Location
    Adelaide, AUSTRALIA
    Posts
    472
    +1
    15
    Sounds like an alignment thing to me. How confident are you that the alignment was done?? I have heard of plenty of horror stories where deleted tell the customer they have done it bit really haven't thinking the customer would not know the difference. I have caught one dealer out telling me he had done something when he hadnt.

  8. +1 by:


  9. #8
    Pete1027's Avatar
    Join Date
    Jul 2012
    Location
    Adelaide, AUSTRALIA
    Posts
    472
    +1
    15
    Dealer sorry not deleted.

  10. #9
    kaiser's Avatar
    Join Date
    Jan 2008
    Location
    western pa.
    Posts
    138
    +1
    6
    Motor mount issue?

  11. #10
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,600
    +1
    590
    I cant see how motor alignment is causing your pump seal/o-ring to twist?? I have seen lots of issues due to alignment but just cant see the o-ring twisting or breaking the pump support.....

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. (Damaged) Pump Support Question
    By Snoman in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-13-2006, 06:37 AM
  2. Time for a new pump support
    By Mark S in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-11-2006, 10:46 PM
  3. do pump support fins have any purpose
    By macattack in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-10-2005, 09:56 PM
  4. Are sharks plastic fins in the pump support needed
    By macattack in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-04-2005, 11:50 AM
  5. pump support replacement
    By zoom zoom in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-03-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •