Results 1 to 5 of 5
  1. #1

    Join Date
    May 2015
    Posts
    14
    +1
    1

    96 slt 780 question internal

    Hello all my 96 slt 780 just broke a connecting rod on the mag cyl there is oil in the bottom of the case ( not much but there is no sign of scoring on the crank where the rod was connected just peices of rod under the piston the case has minor damage but looks salvageable. It happened at about 3000 rpm just sounded like a spoon rattling in a jar there was no engine noise before the moment it popped is this common on these skies within 3 hours I lost 3 of these motors one rod and 2 seized and one and your first thought when u read this is incorrect all 3 had better than half tank of oil (amsoil) hp marine gas was 91 off from esso 5 gallons in each could this be gas related? Having owned a polAris sled in the past I have done cylenders before and after eAch ride I check the plugs always been a nice coffee color I checked all 4 skies including the one that still runs and the plugs are all grey how could all these get that lean that fasts? I'm sure as he'll not buying any lottery tickets this week lol
    any input would be great thanks rob


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,560
    +1
    2,712
    You used the same fuel source, on the same day, in all three machines and all three failed the same day?

    Sounds like bad fuel ...

    Were these machines running properly on days prior to the 'bad fuel' day?

  3. #3

    Join Date
    May 2015
    Posts
    14
    +1
    1
    Yes fuel was all bought at same time put in same time and the plugs on all were checked at the end of last run and all were a nice coffee brown. There was no temp warnings no low oil warnings and it sucked having to pull them home with a Yamaha lol

  4. #4

    Join Date
    May 2015
    Posts
    14
    +1
    1
    All were working very well prior to there last dance

  5. #5

    Join Date
    May 2015
    Posts
    14
    +1
    1
    Just took number 2 apart same end cylender broken rod lots of debris on top or chewed up piston

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 780 Electrical box rebuild question.
    By Rustynuts in forum Polaris Open Discussion
    Replies: 6
    Last Post: 01-29-2022, 10:12 PM
  2. 96 SLt 780 Casrb Questions
    By deman824 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 03-20-2010, 11:55 AM
  3. 96 SLT 780 Crankcase
    By kabadou in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-07-2007, 11:37 AM
  4. 96 SLT 780 f/a upgrade?
    By Ibreakstuff in forum Polaris PWC Performance
    Replies: 2
    Last Post: 05-16-2007, 10:27 AM
  5. 96 SLT 780 questions
    By BBCaprice in forum Polaris Open Discussion
    Replies: 13
    Last Post: 05-14-2007, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •