Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Sl750 issues

  1. #1

    Sl750 issues

    Alright guys,
    i have a brain bender for you all. So I rebuilt my 750 carbs and put them back on, I proceeded to test the ski it idles great, but if you give it any throttle it starts to bog out, choked just kills it, has new plugs, compression great m135 c130 p135, upgraded fuel system pump and all, check all the vacuums lines all is good, I also pulled carbs that I know work good off of my sl650 and it also dose the same.


    any ideas would be really appreciated 😊
    thanks chris


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,641
    +1
    1,632
    Does it idle correctly in the water? What is your in water idle RPM?

  3. #3
    It idles great, I'd say about 1k rpms

  4. #4
    Bad fuel pump or clogged filter?

  5. #5
    New triple pump, and new filter

  6. #6
    fuel check valve maybe?

  7. #7
    Where is the fuel check valve?

  8. #8
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,641
    +1
    1,632
    Quote Originally Posted by Mazdaguy View Post
    New triple pump, and new filter
    OEM fuel filter or generic aftermarket?

    Original gray Tempo fuel hoses or new fuel hoses? Does this model have an OEM fuel flow restrictor inside the return fuel hose? I always forget which Fuji engines and years needed that little restrictor

    Original fuel selector valve?

  9. #9
    Oem filter, hoses where new when I got it, didn't have a restrictor, it has the bs38 carb that has the built in one, original fuel selector, ( I have it hard line right now for testing so no shut off)

  10. #10
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    895
    +1
    21
    Sounds rich to me.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 93 SL750 issues / How's my wash?
    By xkursion in forum Polaris Open Discussion
    Replies: 10
    Last Post: 10-12-2012, 09:01 AM
  2. sl750 issues (LONG POST WARNING)
    By shadooky in forum Polaris Projects
    Replies: 15
    Last Post: 10-11-2011, 08:43 PM
  3. SL750 Fuel/Cooling Rail Issues
    By kepneriphone in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-06-2009, 09:07 PM
  4. '95 sl750 rpm issues
    By scrappy in forum Polaris PWC Performance
    Replies: 5
    Last Post: 09-24-2008, 03:53 PM
  5. sl750 fuel issues
    By sour_krout in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-27-2008, 03:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •