Results 1 to 6 of 6
  1. #1

    99 GP1200 pipe leak issue

    Just put a Gp1200 non-pv I picked up back together with an SBT motor. Hooked it up to the hose, and it fired up, but a TON of water is coming out of the pipe, before the silicone coupler joint. Is that normal on the hose?


  2. #2
    It is POURING from where I am pointing - not from the silicone joint, but before.....Click image for larger version. 

Name:	2015-07-03 15.53.02.jpg 
Views:	39 
Size:	68.5 KB 
ID:	364212

  3. #3
    I believe that IS normal. It's basically a "water jacket". I believe its purpose is to cool the exhaust pipes down. That is why you should also have that black rubber coupling piece on top of that part also.

  4. #4
    What piece?

  5. #5
    OH. I found it. haha. Makes sense now

  6. #6
    Yep. Glad you found it. Btw looks like you have some high comp head you got there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 GP1200 mid range bog issue
    By powerstroke250r in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 04-22-2018, 07:38 PM
  2. Another issue - 02' gp1200 - oil leak on footpads? Pic attached
    By ryffryda in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-26-2016, 01:39 PM
  3. 99 gp1200, weird issue
    By Gp12xx in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 08-02-2013, 03:11 PM
  4. 99 GP1200 Starter Issues
    By Trilogy3337 in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 08-12-2012, 05:25 PM
  5. 99 XLL pipe mod to keep from cracking?
    By snowrunner in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-18-2006, 06:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •