Results 1 to 6 of 6
  1. #1

    2003 Seadoo 4 tec Supercharge burning oil

    Hello. New to the forum. My original supercharger on my 185 GTX was blowing oil into the intake, oil was all the way thru the throttle body and intake. I use the seadoo about two weeks a year, never been in salt. It has 78 hours on it, I am the original owner. I bought a new supercharger from GreenHulk and installed it, works great. I also installed a new aluminium pump, prop and two new oil switches. I changed the oil, oil filter and plugs and ran it this week. I also have the Riva blow off valve kit. It runs great but when you get on it for a little while and then let it idle forward in the water it will start to burn oil and blue smoke. When I removed the plugs to install the new ones I noticed a little bit of oil on all 3 plugs. I am wondering if I have some bad rings? or is it left over oil in the intake from the old supercharger blowing oil and it is burning it off. I went thru couple tanks of fuel this week but still burns oil after idling. Also I have had no alarms or codes go off. I will buy a compression checker to see if compression is down, but the seadoo is running at top speed around 55-56 mph. Thoughts? Thank you.


  2. #2
    achavanne3's Avatar
    Join Date
    Jun 2014
    Location
    Louisiana
    Posts
    130
    +1
    7
    blowing oil into air intake?

  3. #3
    Quote Originally Posted by achavanne3 View Post
    blowing oil into air intake?
    Yes there was oil in the air intake before I put the new supercharger in.

  4. #4
    achavanne3's Avatar
    Join Date
    Jun 2014
    Location
    Louisiana
    Posts
    130
    +1
    7
    Read the thread about oil in sc just posted. I believe yall both have the same problem as well as I do. I cleaned throttle body and air intake tube. Rebuilding mine tonight

  5. #5
    Quote Originally Posted by achavanne3 View Post
    Read the thread about oil in sc just posted. I believe yall both have the same problem as well as I do. I cleaned throttle body and air intake tube. Rebuilding mine tonight
    Ok I will clean it out and try it. Thanks

  6. #6
    Yeah I've just discovered I have this same problem too, replaced mine with a new unit so hopefully I'm fixed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 4 tec supercharger leaking oil
    By Seadoo 03 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-14-2015, 08:32 AM
  2. 2003 Seadoo GTX 185 Supercharge question... Please help
    By Rookiepwc in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-10-2013, 12:43 PM
  3. 2003 gtx 4-tec supercharged do i have a problem?
    By skihead in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-02-2013, 10:41 AM
  4. 2003 Seadoo 4-Tec GTX for sale...
    By brittrich in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-12-2012, 09:25 AM
  5. Replies: 58
    Last Post: 10-17-2010, 07:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •