Results 1 to 4 of 4
  1. #1

    95 spi wont start

    so here is a puzzle. like I said 95 spi 580 will start and run great, then out of the blue if I shut it off after running for an hour. it will not restart.
    it will turn over but not start. after you let it set for 1-2 hours it will start again.
    when its running no problems, runs great..
    anyone have a clue?????


  2. #2
    I need some help!!! anyone have any idea`s

  3. #3
    Waterluvr's Avatar
    Join Date
    Mar 2015
    Location
    Northern Indiana
    Posts
    478
    +1
    69
    Warm or hot restart issues are often fuel related from pressure leaks stemming from the o-ring on the seat base or incorrect pop off pressure from a leaking needle and seat.

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,199
    +1
    172
    Sounds like a bad stator. Check for spark and AC voltage output from the stator when hot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SL750 wont start
    By buffalomoz in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-11-2015, 08:06 PM
  2. 94 seadoo spi, try and try again... she wont start in water
    By jhedges22 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 08-31-2013, 08:10 PM
  3. 95' Blaster w/ 701 engine wont start
    By Ilovehotdogz in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-11-2013, 05:41 PM
  4. 95 yama wave venture cranks wont start,help!!
    By ranger5456330 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-09-2010, 01:01 PM
  5. 95 SL 650 Wont Start
    By rickyman35 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-20-2009, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •