Results 1 to 7 of 7
  1. #1

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    630
    +1
    17

    Oem bilge pump hose vent

    Why is there a vent hole in the oem bilge pump hose?

    I noticed when I filled my hull with water to test the bilge water comes out the vent hole, vent hole is pointing up and is at the highest point as per instructions.


  2. #2
    micromike's Avatar
    Join Date
    Jun 2015
    Location
    uk
    Posts
    1
    its to stop the bilge becoming airlocked

  3. #3
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    849
    +1
    91
    Quote Originally Posted by BEECHFRONT View Post
    Why is there a vent hole in the oem bilge pump hose?

    I noticed when I filled my hull with water to test the bilge water comes out the vent hole, vent hole is pointing up and is at the highest point as per instructions.
    To prevent the siphon effect through the hose, (when installed acc. BRP close to the waterline).
    But when your outlet is high enough above the waterline (like most members here) you can blind this hole with tape.

    https://en.wikipedia.org/wiki/Siphon

  4. #4

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    630
    +1
    17
    I understand the theory, but who wants salt water pissing all over there motor through this vent hole while draining the bilge.

    This is a suspension ski so it not real easy to replace the oem hose with regular heater hose

    Can I just cover the hole with silicone caulk?

  5. #5
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    849
    +1
    91
    As said I used some electrical tape, for that reason

  6. #6

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    630
    +1
    17
    yes but mine is below waterline near ibr cover as per instructions

    Quote Originally Posted by EVN81 View Post
    As said I used some electrical tape, for that reason

  7. #7
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    849
    +1
    91
    Quote Originally Posted by BEECHFRONT View Post
    yes but mine is below waterline near ibr cover as per instructions

    Quote Originally Posted by EVN81 View Post
    As said I used some electrical tape, for that reason
    Ah ok, than leave it open !!

    If it's also wired up acc. BRP specs it's always running when the DESS key is on.

    When the pumps stops (you pull the key) there's a theoretically chance of water siphoning back.

    Because the outlet is close to / under the waterline and the bilge pump is lower inside the hull.

    So after you do a lunch brake somewhere you can find your ski half sunken after.........

    This setup from BRP is not very smart. Can you imagine if this tiny hole get's clogged after a while.......

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WHOEVER Doesnt have a OEM bilge pump....
    By liftd in forum Sea Doo Spark
    Replies: 11
    Last Post: 05-15-2016, 11:00 PM
  2. HOW TO: Install OEM Bilge Pump 2010 Seadoo rxtx 260
    By Scott in forum Sea Doo How To & FAQs
    Replies: 23
    Last Post: 08-15-2015, 01:09 AM
  3. HOW TO: Install OEM Bilge Pump 2010 Seadoo rxtx 260
    By Scott in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-28-2010, 01:38 PM
  4. Bilge pump location for OEM bracket ?
    By mrbtd in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 04-18-2007, 09:40 AM
  5. OEM BILGE PUMP WITH ONE WAY CHECK VALVE
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 01-20-2006, 01:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •