Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991

    2010 RXT-X not tracking straight...

    Bone stock. Seems like it I am constantly correcting it back to center at 25-40mph because it wanders slightly. I do ride bow up mostly. Is an aftermarket grate the solution? If so, what is "the" grate for the RXT-X?


  2. #2
    BigDfromTN's Avatar
    Join Date
    Jun 2015
    Location
    Bath Springs, TN
    Posts
    20
    +1
    1
    First time out on my 06 RXT I noticed the same type of thing. To me it just don't ride right till at least 35 mph. Mine tends to slightly wander, and even ride off level to one side or the other at low to mid range speeds. Idle is fine and above 35- 40 is fine too.

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,998
    +1
    769
    Click image for larger version. 

Name:	IMG_0632.jpg 
Views:	103 
Size:	50.1 KB 
ID:	363934

    Your steering nozzle needs to be adjusted.

    Raise the iBr gate with the IBR OVR steps, in the Owners Manual.
    Remove the bolt and nut on the steering nozzle with a 10mm wrench and socket wrench.
    Turn the turnbuckle 2 revolutions, tighten set nut.
    Reinstall the bolt and nut.
    Go test your adjustments - repeat until tracking straight.

  4. #4
    PWC Addict Magnummmmmmmmmm's Avatar
    Join Date
    Jan 2014
    Location
    SML, VA
    Posts
    337
    +1
    47
    My 13 rxt x pulls slightly to the left even though the steering is centered. I think a slight variation in where the pump mounts to the transom causes the whole pump to be ever so slightly out of alignment to the hull. I may try using some pump shims off one of my old xps and see what happens.

  5. #5
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    Quote Originally Posted by jpt7779 View Post
    Click image for larger version. 

Name:	IMG_0632.jpg 
Views:	103 
Size:	50.1 KB 
ID:	363934

    Your steering nozzle needs to be adjusted.

    Raise the iBr gate with the IBR OVR steps, in the Owners Manual.
    Remove the bolt and nut on the steering nozzle with a 10mm wrench and socket wrench.
    Turn the turnbuckle 2 revolutions, tighten set nut.
    Reinstall the bolt and nut.
    Go test your adjustments - repeat until tracking straight.
    When I say not tracking straight, I really dont mean steering. It's almost like it wants to wander off the center line. It just doesn't feel as planted. Maybe that makes better sense.

  6. #6
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    7,309
    +1
    1,329
    Quote Originally Posted by Magnummmmmmmmmm View Post
    My 13 rxt x pulls slightly to the left even though the steering is centered. I think a slight variation in where the pump mounts to the transom causes the whole pump to be ever so slightly out of alignment to the hull. I may try using some pump shims off one of my old xps and see what happens.
    Check the torque on each pump shoe bolt INSIDE the hull first. I'll bet they are not to spec......torque to 16 Ft/lbs.

  7. #7
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,060
    +1
    679
    If the grate or plate are not leveled and you have a protrusion this will be the result. The entire ride area needs to be level.

  8. #8
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,255
    +1
    991
    Rode the 2013 GTX again and it's about the same. I guess I am just used to my FZR with sponsons, grate and Jim's cut 2014 FZ plate.

  9. #9
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    321
    i rode my girlfriends gti155 and experienced the same thing this past weekend i thought the steering was way out of wack and once i got over 30 it tracked dead straight, so hers did wander around as well.

  10. #10
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,060
    +1
    679
    Quote Originally Posted by Branden View Post
    i rode my girlfriends gti155 and experienced the same thing this past weekend i thought the steering was way out of wack and once i got over 30 it tracked dead straight, so hers did wander around as well.
    Evan has a 155?

  11. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 sea doo rxt 215 not cranking over
    By steve76s in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-06-2015, 10:24 PM
  2. 2010 Rxt 215 Will not move
    By Dhenry6149 in forum 4-Tec Performance
    Replies: 15
    Last Post: 06-03-2015, 04:44 PM
  3. 2010 rxt 215 will not go over 35/40 any idea why
    By Dhenry6149 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-06-2014, 01:24 PM
  4. WTB Stock 2010 rxt-x ecu either us or eu - does not matter
    By andrew1975 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-26-2012, 09:10 AM
  5. 2010 RXT-X buttons RH not working sometimes
    By dutchrxt in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-16-2012, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •