Results 1 to 5 of 5

Thread: 1997 xp no beep

  1. #1

    Join Date
    Jun 2015
    Posts
    6

    1997 xp no beep

    we have a 97 xp we replaced the starter on. when we put the key in we get no beeps... put a brand new battery in and still nothing, when we tap on the solenoid it will turn over but still no beeps and no start any suggestions? Thanks


  2. #2
    Waterluvr's Avatar
    Join Date
    Mar 2015
    Location
    Northern Indiana
    Posts
    478
    +1
    70
    Good news is the security on your MPEM is unlocking and powering the start circuit, so on the backside of that the beeper has probably failed which is pretty common and the relay is going to need replaced if the starter has been already. Any relay that's seen a period of use when the ski has been hard to start and cranked excessively has been hurt and a new one cleans things up nicely most of the time.

    Radio Shack offer's a replacement beeper for a fraction of the cost the Floyd Bell unit sells for at a dealer parts counter, this is what your looking for.


  3. #3

    Join Date
    Jun 2015
    Posts
    6
    OK thank you, we will try that.

  4. #4

    Join Date
    Jun 2015
    Posts
    6
    do you think the solenoid needs replaced as well?

  5. #5
    Waterluvr's Avatar
    Join Date
    Mar 2015
    Location
    Northern Indiana
    Posts
    478
    +1
    70
    Quote Originally Posted by jkhill View Post
    do you think the solenoid needs replaced as well?
    They almost always do on an older machine, the internal relay doesn't function 100% and it's a weak link between the cranking amps and voltage in the battery making it's way to the starter motor.

    Also, test the cables for resistance if they are in bad shape they rob quite a bit of power from the starter. I keep an Earth X lithium battery on hand to install in customer's ski's that have electrical systems that need help just to illustrate how tired and slow everything works on their typical lead acid battery that ran everything fine when new, now not so much it literally takes twice the battery power to get a fast crank and reliable start out of it 15-20 years later on the original cables and relay.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '96 XP No beeps, but starts, now just cranks
    By jamesbern in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-18-2012, 07:19 PM
  2. Xp no beep or power
    By derwin66 in forum 2-Stroke Performance
    Replies: 12
    Last Post: 03-23-2012, 10:06 PM
  3. 97 XP No Beep or start
    By jetskiperf1 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-02-2010, 10:49 AM
  4. 98 XP No beeps no anything please help me....
    By xpl951mc in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-14-2009, 08:13 AM
  5. 99 xp limited no beep
    By icerat4 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-31-2008, 09:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •