Results 1 to 3 of 3
  1. #1
    Bdesim's Avatar
    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    293
    +1
    10

    2003 seadoo xpdi first issue

    Earlier this year I purchased 2 low hour MINT condition 2003 xpdi's they have been awesome and problem free until now.

    I have read through a lot of threads regarding these skis and am familiar with some of the known issues. I just wanted to get some opinions before I start to tear into the ski that I am having issues with.

    I have owned and worked on many skis in the past of all different brands but these are my first seadoos so I'm just looking for a little guidance.

    Here's the problem:
    When trying to start the ski I put on the key and get the familiar two beeps. I do NOT hear the fuel pump power up. Ski has 0 fuel pressure. If I dribble gas into the spark plug holes ski will start.

    Here's what I have checked so far and my questions:
    1) fuses on by the mpem... Are there more ? Or just those?
    2) checked all electrical connections to the fuel pump everything looks fine. Could it just be a bad pump?

    The good news: I have the second ski to swap parts for testing and I know the mpem is good. (Starts the other ski)

    Any Help would be greatly appreciated. As I said I'm new to the xpdi but so far I love the skis

    Thanks,
    Brian


    Sent from my iPhone using Tapatalk


  2. #2
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    5,130
    +1
    527
    You need to backprobe the fuel pump connector and check for 12v when powering up or cranking.

  3. #3
    Bdesim's Avatar
    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    293
    +1
    10
    Thanks. I will check this and report back. I'm hoping it's something simple. But from what I've been reading, it never is with these DI machines.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 seadoo gti rfi issue
    By Ladykarter in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-17-2013, 04:37 AM
  2. 2003 seadoo xpdi cutoff relay blowing fuse.....
    By 13xracing in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 03-07-2012, 07:30 PM
  3. 2003 Seadoo XPDI
    By 2blue in forum 2-Stroke Performance
    Replies: 30
    Last Post: 01-21-2011, 10:25 PM
  4. 2003 Seadoo XPDI Parting Out Monday
    By 2blue in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-30-2009, 07:01 PM
  5. 2003 Seadoo Xpdi For Sale $5000
    By monsoonmadness in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 06-12-2008, 04:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •