Results 1 to 4 of 4

Thread: Help

  1. #1

    Help

    I was given a 1992 waverunner 500 the starter just clicks when I go to start it but drive shaft and pistons rotate. When I take the spark plugs out and hit the start button it turns over fine. The battery is dead but I had to hooked up to a jump box. Any ideas?


  2. #2
    dockwalker's Avatar
    Join Date
    Mar 2010
    Location
    On the water near Belhaven,NC
    Posts
    355
    +1
    19
    You need a new battery.Takes a lot of amps to turn it over.

  3. #3
    Quote Originally Posted by dockwalker View Post
    You need a new battery.Takes a lot of amps to turn it over.
    That jump box has jumped many of cars and small trucks with v6

  4. #4
    check your connections for the positive and ground. It's a battery/cable issue for sure

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-20-2018, 11:35 PM
  2. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  3. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  4. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  5. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •