Results 1 to 3 of 3
  1. #1

    Xlt 1200 revs, but won't go.

    Here recently my 2001 xlt1200 has been struggling to take off. It will hit about 10 mph and then just rev real loud but won't go anywhere. I'm guessing it's something to do with the jet system?


  2. #2

    Join Date
    Apr 2010
    Location
    Australia
    Posts
    55
    +1
    1
    Get it out of the water and make sure the intake grate is clear of any debris and nothing is wrapped around your drive shaft.

  3. #3
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,544
    +1
    194
    sound like your intermediate shaft and drive shaft splines are done.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starts and idles good. Squeeze throttle and lugs, runs but won't go over 5mph
    By Fandini in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 10-10-2014, 12:42 PM
  2. Seadoo starts but won't go
    By Fabgreg in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-09-2014, 09:40 PM
  3. Help!... 705sl revs but doesn't go?
    By Ron Welch in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 04-22-2012, 01:39 PM
  4. Waverunner XLT 1200 won't go over 20 MPH after taking on water
    By mmr11408 in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 07-07-2008, 06:04 AM
  5. Revs, but won't go
    By Ruski in forum Yamaha Open Discussion
    Replies: 9
    Last Post: 07-26-2007, 03:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •