Results 1 to 4 of 4
  1. #1

    Repaired emm New tps no rpms in water

    I had repaired emm and then put in working tps in machine ran great for a while. After a long ride the machine began to only run up to about 2100 rpm wot. 2002 virage txi. Any ideas? Swapped out old tps with brand new one. Still no help. After pulling out if water engine would throttle right up to high rpms.


  2. #2
    I like pipes. I love boost Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,263
    +1
    1,449
    I would check compression first. It seems we forget to check mechanical condition of these engines when dealing with the DI systems. I would also verify your fuel pressure.

  3. #3
    Fuel pressure good, I'll check compression asap. Does it make logical sense that the motor would suddenly lose compression?

  4. #4

    Join Date
    Jun 2015
    Location
    Chapel Hill, NC
    Posts
    72
    +1
    3
    it does if you blow a hole through one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 07-30-2008, 10:42 PM
  2. No power in water
    By agentslinger in forum Polaris Open Discussion
    Replies: 30
    Last Post: 06-17-2008, 10:49 PM
  3. raider 760 no power in water
    By AintStuck4x4 in forum Yamaha Old School Skis
    Replies: 15
    Last Post: 06-15-2008, 10:58 PM
  4. 1999 Polaris Genesis no power in water
    By kingjon3rd in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-05-2008, 06:59 AM
  5. 250X idles at 2200 RPM in water
    By kman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 09-11-2007, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •