Results 1 to 8 of 8
  1. #1

    Join Date
    Aug 2009
    Location
    Dayton, Ohio
    Posts
    41
    +1
    1

    2004 MSX 150 does not want to run above 3450 RPM, except when it does

    not to walk on another man's post,,, BUT !!!
    I have a 2004 MX150 here and does the same thing sorta, what's a SIBF??

    If you don't mind Mike may I ask this.
    Her's ran fine then her son rolled over at 5mph.. but rolled it upright in wrong direction,, SOOO he rolled it back over the correct way TWICE to make up for it?DUH? by then I suspect the bilge was full of water above the air intake and he started it ran it back to dock smoking badly. Engine oil was contaminated so I pulled and washed intake, oil separator, inner-cooler. It would only go 3500rpm. Sent computer to Canada to have it read and reprogrammed with different fuel curve and ???. Still 3450rpm. Sent it back this time with most of the sensors. He said some were bad and so he sold me new ones. He said he put all her parts in his personal ski and went almost 77mph.. I installed the new parts and still 3450rpm. She only putts around so she lived with it for a year. Last summer it began not starting when hot (not overly hot but just ran it change drivers and no start). If you pull the injector wires off and crank it a bit it will start run out of gas and die. Hook up injectors and she'll start up and run. Then it began where if you hit a bump (wave) just right it will take off like a rocket 70 mph-ish occasionally. Then it got where it would only go 30, then 20, then 15mph. Will die and not restart even with the injector trick... The boost gauge shows turbo boost when it's running and it sounds like it is dumping (waste gate) on the few times it takes off, (it seems to like to go fast at the wrong times so you have to let off abruptly and pop goes the gate). OH''She just told me the last couple of times she took it out the first time in the water (for that day) she would Always idle just at plane for 4 to 5 minutes to warm it up only on a couple of trips she would have to drive it for 10 to 20 minutes before it would run faster than 10 or 15 mph max. Once it would go it would go up to 45mph then slowly back down to a max of 3450rpm?

    PS Should I start a new post. I'm not much of a forum person (newbie)


  2. #2
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Hi Brunoski
    The SIFB is a small square module with a connector to plug into the wire harness. It is located in the wire harness directly above the battery... probably ziptied in there. This SIFB is responsible for auto-power-down of the ignition system when the ski is off and the lanyard is left IN. It also translates the reverse engaged switch signal for the ECU. If your having any sort of 3400 rpm ECU rev-limit... the SIFB is the main suspect. If your having weird startup/shutdown issues... the SIFB is also a suspect.

    Randy at WeberPower has new aftermarket SIFB modules. But the new ones remove the auto-power-down (w/ lanyard IN) feature... so you have to pull the lanyard OUT or the battery will drain.

    A lot of what your describing makes me very suspect of the SIFB. You might try a new one.

    Cheers!

  3. #3
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    736
    +1
    63
    These guys will point you in the right direction

  4. #4
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    736
    +1
    63
    As to being a problem that is on/off, could the inter cooler be oiled up partially then somehow allowing boost to pass as it hit a wave? Thoughts?

  5. #5
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,449
    +1
    300
    Intercooler is like a radiator, so I don't think it would behave as you are asking, unless there was fluid sloshing around where the air passes through. But you'd likely have a lot worse problems if that were the case.


  6. #6
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Not following what you mean by the IC passing boost as you hit a wave?? What are you experiencing?

    As Hiperco said (I'm saying that alot lately... nice!)... it's possible if you didn't remove the IC to thoroughly clean it out... that it still has oily gunk in it's depths. This gunk could then get blown out under full boost and waves and whatnot. Like coughing it up occasionally... which then hits the hardpipe MAP... fouls it... and sends the ECU back to wonkytown.

    Glad the SIFB worked. Don't forget to always pull your lanyard OUT when ski is off.

    Cheers!

  7. #7
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    736
    +1
    63
    No guys brunoski killed my post. He was asking a whole different question. And hopefully will learn to stare this own thread ..........hint! He was asking about his own separate set of issues. You guys already OWN my solution!

  8. #8
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,494
    +1
    2,705
    Quote Originally Posted by Mike Greenwood View Post
    No guys brunoski killed my post. He was asking a whole different question. And hopefully will learn to stare this own thread ..........hint! He was asking about his own separate set of issues. You guys already OWN my solution!
    Posts moved to a new thread.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Msx 150. Am I supposed to see the wast gate open when reved on trailer????
    By 123emadt in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 07-04-2014, 09:19 AM
  2. 2004 MSX 150 will not stop running
    By tsummerl in forum MSX/Matrix
    Replies: 11
    Last Post: 11-18-2012, 09:57 PM
  3. how to winterize a 2004 MSX 150
    By yzman127 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-28-2010, 07:30 PM
  4. 2004 MSX 150- Help! I had to get towed back to dock!
    By angelsfann02 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-14-2009, 07:15 PM
  5. 2004 MSX 150 will not stop running
    By tsummerl in forum Polaris Open Discussion
    Replies: 4
    Last Post: 11-13-2008, 05:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •