Results 1 to 6 of 6
  1. #1
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    640
    +1
    13

    99 gtx ltd speedo troubleshooting

    I have a 99 gtx I am helping a friend with and it seems the new wheel asm did not fix the issue. The old wheel asm was not giving off any voltage but this one is only giving off 2-4 v. The book calls for 5.5-8.5V. Anyone have any thoughts on how to troubleshoot this problem. The new wheel asm is brand new.


  2. #2
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,405
    +1
    170
    That voltage check is the only check for these really, if it's only reading 2-4 volts you got a bad wheel assembly.

  3. #3
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    640
    +1
    13
    That is strange. Brand new asm. $150. I will have to contact the vendor. Thanks for that reply!

  4. #4
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    640
    +1
    13
    Installed another new paddle wheel and same result. So this makes 2 new paddle wheel sensors that have the same amount of voltage. Both asm were new from the factory. What about a shorted multi-meter? That gauge does send a signal to the mpem which in turn sends voltage to the paddle wheel asm.

  5. #5
    You have a messed up gauge, paddle wheel is fine. Let me explain how this works. (I have done a lot of work with these systems when we developed our line of GPS speedometer modules...)

    First of all, the MPEM does absolutely nothing, it is simply a pass-thru connection from the gauge to the paddle wheel. The gauge controls everything. The info gauge supplies power to the paddle wheel assembly thru a resistive network, with nothing connected to it, it supplies near 12 volts to the paddle wheel power wire. The hall-effect circuit in the paddle wheel is powered by this line, and at the same time, it switches, or more correctly, loads this line with enough resistance to draw the voltage down to between 5 and 8 volts or so as it switches. The gauge senses this alternation in the line to provide the speedo function.

    If you are only seeing a few volts when a good paddle wheel is connected, then the gauge or connections to the gauge are faulty.

  6. #6
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    640
    +1
    13
    Thanks a bunch! I will swap out that info gauge as soon as I can!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need MPEM for 99 GTX LTD
    By m1man in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-17-2011, 12:45 PM
  2. 99 gtx ltd bilge
    By jnz in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-27-2010, 01:36 AM
  3. WTB 99 gtx ltd venutri
    By rxp127 in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 10-04-2009, 12:49 PM
  4. 99 gtx ltd ,wet spark plugs
    By jesses in forum 2-Stroke Performance
    Replies: 12
    Last Post: 09-08-2009, 08:06 PM
  5. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •