Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Feb 2015
    Location
    North Carolina
    Posts
    96
    +1
    8

    GPRXP Conversion Help

    I have a GPRXP conversion ski. I am having an issue and would like some input. While riding, it will intermittently lose power. It does not cut off, just loses power, and just for a split second. So naturally I let off the throttle. This is getting more and more frequent. Any suggestions or help is greatly appreciated. Also seems to do it more often when bouncing around.


  2. #2

    Join Date
    May 2012
    Location
    California
    Posts
    1,824
    +1
    163
    have you checked your supercharger? How many hours on it? I would check that first because it can destroy your motor easily.

  3. #3

    Join Date
    Feb 2015
    Location
    North Carolina
    Posts
    96
    +1
    8
    I have not. It happens even at cruising rpm's. Would that matter?

  4. #4
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    you have an electrical connection issue imo

  5. +1 by:


  6. #5

    Join Date
    May 2012
    Location
    California
    Posts
    1,824
    +1
    163
    check the grounds on the front of the motor, when it loses power does it shut all the way down or just stumble?

  7. #6

    Join Date
    Feb 2015
    Location
    North Carolina
    Posts
    96
    +1
    8
    Quote Originally Posted by toxicgun View Post
    check the grounds on the front of the motor, when it loses power does it shut all the way down or just stumble?
    just stumbles

  8. #7
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,722
    +1
    3
    did you check gauge for any codes?

  9. #8
    Tedcfitz's Avatar
    Join Date
    Jan 2012
    Location
    Dunn NC
    Posts
    178
    Don told me that it was caused by that brown sensor wire touching the supercharger housing. Make sure no wires are directly contacting the SC housing, or double insulate the wire. Also check any connections for that wire.

  10. #9

    Join Date
    Feb 2015
    Location
    North Carolina
    Posts
    96
    +1
    8
    Quote Originally Posted by Tedcfitz View Post
    Don told me that it was caused by that brown sensor wire touching the supercharger housing. Make sure no wires are directly contacting the SC housing, or double insulate the wire. Also check any connections for that wire.
    Thanks Ted. I will check that.

  11. #10

    Join Date
    Feb 2015
    Location
    North Carolina
    Posts
    96
    +1
    8
    Quote Originally Posted by shooter98xpl View Post
    did you check gauge for any codes?
    No codes.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GPRXP conversion Vent system.
    By Hydrotoys in forum Conversion FAQ and Tips
    Replies: 16
    Last Post: 07-17-2010, 03:39 PM
  2. Hydrojunkie's Gprxp Conversion
    By hydrojunkie in forum Conversion PWC Performance Skis
    Replies: 296
    Last Post: 09-07-2009, 06:39 PM
  3. Jeffsntx's GPRXP conversion
    By jeffsntx in forum Conversion PWC Performance Skis
    Replies: 143
    Last Post: 06-22-2008, 03:24 PM
  4. GPRXP Conversion project
    By idizzy in forum Conversion Skis Classifieds
    Replies: 19
    Last Post: 02-01-2008, 10:57 PM
  5. GPRXP Handling Parts Selection - Help - Experienced GPRXP'rs Help me pick out parts!
    By boostaholic in forum Conversion PWC Performance Skis
    Replies: 9
    Last Post: 01-16-2008, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •