Results 1 to 4 of 4
  1. #1

    Unhappy 2004 Polaris mx150 charging system problems

    My 2004 Polaris MX150 runs great except the battery light comes on every 1/2 hour of operation and I have to take it to shore and change batteries and then the new battery only lasts 1/2 hour. How do I check and repair the charging system? Thanks,Pete


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,521
    +1
    2,709
    What does your multimeter say the battery voltage is when the engine is running?

    What age and type is the battery?

  3. #3
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,048
    +1
    256
    It is most likely a voltage regulator. If the battery takes a charge on a charger it sounds like a regulator is out. It could also be a fuse. Check all fuses in all three fuse blocks.

  4. #4
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,644
    +1
    213
    Welcome to GH!

    Assuming you have a strong, healthy battery to start with (a must)... charge it up and put it in the ski. Start the ski and put a volt meter across the battery terminals and tell us what voltage you are reading at the battery with the engine idling.

    More than like, if everything is running properly and you are having no other issues... or other check engine lights... then it's likely the voltage regulator has gone bad. The VR is a bugger to get to... so I would suggest you just carefully unplug the current one and just leave it where it is... then plug a new one in to the connector and ziptie it somewhere secure... like around one of the intercooler freshwater cooling hoses.

    The VR is at the front of the engine, under the intercooler, under the intercooler. See the pic.

    Click image for larger version. 

Name:	MSX_VR_pic.JPG 
Views:	81 
Size:	74.3 KB 
ID:	363008

    Let us know how it goes.

    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 ultra 150 charging system problem
    By big john in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 10-08-2012, 04:28 AM
  2. 2004 Polaris MSX 110 PPS Problems Part # 2410446
    By doug2005 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-03-2011, 12:20 PM
  3. charging system problem
    By piper250 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-17-2011, 06:57 PM
  4. charging system problem
    By piper250 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-28-2011, 04:55 PM
  5. 2004 FX HO Charging System
    By whitey436 in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 10-29-2009, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •