Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    523
    +1
    47

    Quick Question about rpms

    At what rmps is the 215 rxp suppose to run at when full throttle.

    My rps don't bounce around but peaking is about 7700 rps, what could cause this?


  2. #2
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    523
    +1
    47
    Could it be something to do with the after market stuff.

    Currently have

    Riva thru hull
    Intake grate
    Solas 14/19
    Riva sponsons

  3. #3

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    you need my TDR water box to make the hp to run that setup-- you can pick it up at my house or I can send it. Let me know If you do want to pick it up, give me some notice and I will have my no. 1 ski here-- I will let you try it out.

  4. #4
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    523
    +1
    47
    Quote Originally Posted by jim View Post
    you need my TDR water box to make the hp to run that setup-- you can pick it up at my house or I can send it. Let me know If you do want to pick it up, give me some notice and I will have my no. 1 ski here-- I will let you try it out.
    You being serious that i need that water box or a sales pitch!! lol

    Where you located?

    I took the ski out today and max rpm i seen was 7700 wasn't WOT for long, but it was also 85 today with lake temp of 77

  5. #5
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    What rpm did it run at before the mods ?

  6. #6
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    523
    +1
    47
    Well i bought the skit used, with only a 14/19 on it with the riva seat. I added the Grate, thru hull, and sponson.

    Before i added the stuff i added i think if i remember correctly it was closer to 8k that was 3 years ago i got it.

    I don't ride alot so i never pay alot of attention! Just something i noticed today while i was out.

  7. #7
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Have you rebuilt the supercharger ?

  8. #8

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    Quote Originally Posted by 05rxp05 View Post
    Quote Originally Posted by jim View Post
    you need my TDR water box to make the hp to run that setup-- you can pick it up at my house or I can send it. Let me know If you do want to pick it up, give me some notice and I will have my no. 1 ski here-- I will let you try it out.
    You being serious that i need that water box or a sales pitch!! lol

    Where you located?

    I took the ski out today and max rpm i seen was 7700 wasn't WOT for long, but it was also 85 today with lake temp of 77
    pm sent.

  9. #9
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    523
    +1
    47
    Quote Originally Posted by dpracing View Post
    Have you rebuilt the supercharger ?

    Super charger was rebuilt at 100hrs currently have 115 on it!

  10. #10
    Kenway's Avatar
    Join Date
    Apr 2012
    Location
    Newfoundland
    Posts
    76
    +1
    1
    Ran my RXP yesterday at full throttle. 8000 rpm on display and gauge. Only mod I have yet is 14/19 solas impeller.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. quick question about impeller..
    By ryan*9 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 01-04-2008, 11:36 PM
  2. Quick Question About Fogging The 4-tec Engine?
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 10-21-2007, 09:14 PM
  3. Quick question about piston rings
    By xltrider in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 05-14-2007, 02:05 PM
  4. Quick question about CDI wiring
    By bobolie in forum Polaris PWC Performance
    Replies: 4
    Last Post: 05-12-2007, 12:58 PM
  5. quick question about clutch failure
    By SHIFT in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-28-2007, 09:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •