Results 1 to 8 of 8

Thread: Error code 142

  1. #1
    dixon0001's Avatar
    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    543
    +1
    24

    Error code 142

    Just sold a ski and hour on the clock later he rang me up saying it's showing error code 142 I've looked on Internet and it's saying tps sensor and other page saying it could be the butterfly clip could be rusted and my need freeing are theses the same two things ??? Also he said he fiddled around with few wires and it worked ok for bit the code came back on


  2. #2
    What kind of ski and what year?

  3. #3
    dixon0001's Avatar
    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    543
    +1
    24
    Fx sho non cruiser and its a 2008

  4. #4
    Either a harness or TPS, my guess is the TPS. But only real way to tell is by individually testing each. TPS are much cheaper so id try that first,

  5. #5
    dixon0001's Avatar
    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    543
    +1
    24
    Cheers does the tps have some sort of butterfly clip in it

  6. #6
    The throttle body does, but that is a different piece and a bit pricier. You would possibly be throwing a different code if that were the case.

    You are looking for the sensor that the cable from your trigger connecte to

    Located in the storage hole.

  7. #7
    dixon0001's Avatar
    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    543
    +1
    24
    Is this the right part item number 1

    http://www.boats.net/parts/search/Ya...202/parts.html

  8. #8
    dixon0001's Avatar
    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    543
    +1
    24
    Would it not be correct that if the butterfly clip is sticking the tps and throttle body would be sending wrong reading to ecu putting it into limp mode causing the error code ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help - 2009 Yamaha FZR Error Code 142
    By Sandman999 in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 01-28-2019, 07:11 AM
  2. Who has gotten a P-0500 error code?
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-12-2012, 01:18 PM
  3. P-0500 error code??
    By BOOSTED in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-23-2010, 01:33 AM
  4. Sea-doo error code
    By stonylake rxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-18-2007, 10:27 PM
  5. Error code 1517 ????
    By ralphmalph3 in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-10-2007, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •