Results 1 to 4 of 4
  1. #1

    2006 GTX Ltd Won't Start

    Hi All.

    I have a 2006 GTX Limited.

    It ran fine all last season and I winterized it with no problems.

    Today, I put in the battery (fully charged) and when I snapped on the key, the display went thru, what appeared to be, the usual self test.

    Then then display showed the hours, but that was it.

    I did not get the usual BEEP when I put on the key.

    Nothing happens when I push the start button either.

    I disconnected and reconnected the battery but still no beep and won't even turn over/crank.

    I hear no noises whatsoever... no clicking... no nothing !

    I tried jumping the solenoid with no success.

    I put a voltmeter on the battery and it read 12.7V, but then I connected the key, it steadily drew down to 9.7V.

    I am going to try to use a car battery to see if it will crank over.

    Can you give me any suggestion to try, or is it off to the repair shop ?

    Thanks.
    Last edited by pratzert; 06-20-2015 at 04:23 PM.


  2. #2
    UPDATE: I used a car battery and jumper cables. When I connect the key I get the usual long "Beep".

    But when I hit the start button... only clicking. I tried jumping the solenoid but it still would not turn over.

    In lieu of any other ideas, it's off to the shop it goes.

    Thanks.

  3. #3
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    1,004
    +1
    30
    If it sparks hard, then you either have a starter or pump issue. If it doesn't spark at all, or little, probabaly ground issue. Your key ought to give you 2 single beeps when the computer "wakes up".

  4. #4
    Quote Originally Posted by Mighty Mouse View Post
    If it sparks hard, then you either have a starter or pump issue. If it doesn't spark at all, or little, probabaly ground issue. Your key ought to give you 2 single beeps when the computer "wakes up".
    Thanks Mighty Mouse.

    I'll see if I can trace out the ground cables and clean them off.

    Regards

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 GTX SC won't start-just clicks
    By Folly77 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-25-2011, 03:48 PM
  2. 2002 GTX DI won't start
    By GTXDI in forum 2-Stroke Performance
    Replies: 6
    Last Post: 08-03-2009, 01:10 AM
  3. FS: 2006 GTX LTD 45 Hours + Trailer
    By dothedew in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-01-2008, 04:15 PM
  4. Different Model Numbers 2006 GTX Ltd
    By RebelYelle in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 02-17-2007, 02:03 PM
  5. Compass not working 2006 GTX Ltd
    By RebelYelle in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-08-2006, 12:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •