Results 1 to 3 of 3
  1. #1

    Join Date
    May 2015
    Location
    Finland
    Posts
    6

    GTX 4-tec oil warning signal

    After 20min riding, warning led lights up and "OIL" text appears for a few seconds. The oil level is at the upper limit. What might be wrong? Is it possible that oil pressure is too low or oil pressure sensor is faulty? Where oil pressure sensor is located in 4-tec(no turbo)?

    Ski is 2002 GTX 4-tec no turbo charged.


  2. #2
    It will be the rear oil sensor mate under the intake manifold, the one with the single wire going to it. They are known to go faulty.
    I had the same problem.

  3. #3

    Join Date
    May 2015
    Location
    Finland
    Posts
    6
    Thank you Fosta! I changed rear oil pressure switch and no anymore oil warning signal problem. I also measured pressure and it seems to be between 3-5bar from idle to 6000rpm


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 07-22-2013, 02:56 PM
  2. GTX 4-TEC SC - "OIL" Warning but no code
    By OneJESUSGod in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-22-2013, 02:52 PM
  3. 02 gtx 4 tec oil in hull
    By Jessie00721 in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-24-2013, 02:22 PM
  4. Replies: 9
    Last Post: 04-29-2013, 05:43 PM
  5. 03 gtx Di low oil warning
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-30-2012, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •