Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Please help!!

  1. #1
    Timdog's Avatar
    Join Date
    May 2013
    Location
    Guernsey Channel Islands
    Posts
    238
    +1
    28

    Please help!!

    Hi guys and girls,

    im off out for the night in a min and don't have time to search this site as I normally do, I need answers now so in the morning I can solve my problem.

    my fzr 09 suddenly went to 6000 rpm and won't go fast at all prob 40 mph, I'm thinking super charger clutch as there isn't that instant power, what I need to know is how to fix said problem if it is that or other things it might be before I start to tear it down.

    please please anything I can try, links to pages already made for this problem, I will be forever grateful.


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,929
    +1
    560
    sounds like your sc clutch is bad. Here is a link on how to replace sc clutch http://www.greenhulk.net/forums/showthread.php?t=130451 Tommy Jordan

  3. #3
    Banned User
    Join Date
    Sep 2014
    Posts
    1,150
    +1
    132
    Are you sure it's not in learner mode?

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    Quote Originally Posted by riick370 View Post
    Are you sure it's not in learner mode?
    LOL, omg. Derka derr.

    Like Tommy said, clutch.

  5. #5
    Timdog's Avatar
    Join Date
    May 2013
    Location
    Guernsey Channel Islands
    Posts
    238
    +1
    28
    Not in learner mode, there is no noise coming from the supercharger once on tick over like there normally is

  6. #6
    Smokes's Avatar
    Join Date
    Dec 2012
    Location
    WBS
    Posts
    381
    +1
    50
    Check clutch, remove intake and try to spin blade both ways

  7. #7
    Timdog's Avatar
    Join Date
    May 2013
    Location
    Guernsey Channel Islands
    Posts
    238
    +1
    28
    If it is clutch can I put in the 2013 model? I'm sure I read somewhere that is a good upgrade

  8. #8
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    991
    Yes

  9. #9
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,223
    +1
    554
    Quote Originally Posted by Timdog View Post
    If it is clutch can I put in the 2013 model? I'm sure I read somewhere that is a good upgrade
    here is the kit also has the idler gear you will need.
    http://www.4-tecperformance.com/inde...oducts_id=2084

  10. #10
    Timdog's Avatar
    Join Date
    May 2013
    Location
    Guernsey Channel Islands
    Posts
    238
    +1
    28
    Thanks guys took off intake and as suspected blades spins both ways so will up grade to a 2013 clutch. Anything else I can do while I have all that off? Only running stock ic uprated intake and exhaust.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM
  2. 4-Seater jetski with Mercury Jet Propulsion... please help
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-19-2005, 02:18 PM
  3. Please Help!!!!!!!!
    By RXP215 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-15-2005, 10:09 AM
  4. CHEWED UP SOME ROPE TODAY PLEASE HELP
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-07-2005, 02:14 PM
  5. PLEASE HELP MUSIC DOWNLOADING
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-05-2005, 09:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •