Page 1 of 3 123 LastLast
Results 1 to 10 of 30
  1. #1

    Join Date
    Jun 2015
    Posts
    15

    Virage I problems. Please help

    I have a 2002 virage I. The ski cranks up fine and runs well at 50 mph for a short time. After a little while, the rpm starts jumping and the engine starts cutting out. If I come to an idle after this and then try to accelerate, it wont go over 20 mph. Occasionally it will completely cut off, but usually cranks right back up with no problem. The fuel pressure measured to be 16.5 psi. My knowledge of jet skis is very low and I'm out of things to google, so if anyone has any suggestions they would be greatly appreciated.
    Thanks in advance to any help.


  2. #2
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Suffolk, VA
    Posts
    1,442
    +1
    28
    16.5 is a little on the low side. Can you attach a gauge and go for a ride and see if it's dropping under load?

    Could be a number of things;
    Fuel pump going bad
    Fuel regulator not working as it should
    TPS is going/gone bad
    Flywheel magnets came loose
    EMM going bad

  3. #3

    Join Date
    Jun 2015
    Posts
    15
    Thanks for replying. I read somewhere that the psi should be somewhere around 20 so i thought it was a little low too. I don't have a gauge that will allow me to ride with it, but I'll look around and see what I can find for fairly cheap.

    We had a bad fuel pump once before and the mechanic said that the EMM was what ruined it, so we replaced the fuel pump and had the EMM repaired less than a year ago. Do you know of any test that I can do to rule out any of the possible problems that you listed?

  4. #4
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Suffolk, VA
    Posts
    1,442
    +1
    28
    At rest after the ski has been sitting for a few hours, take the inside of the Schrader valve out and clamp the line to the rear of the valve. See if you can blow into the valve. You should not be able to. If you can then it sounds like the FPR is stuck open.

    I'd drop in a new TPS. You should have one as a spare anyway, they commonly fail, and cause odd behavior.

    Pull the CPS out and see if there are any metal shavings or otherwise on it. It should be shiny clean metal.

  5. #5

    Join Date
    Jun 2015
    Posts
    15
    Thanks, I'll do those test when I get home from work and let you know if I find anything.

    Do you know how much a TPS may cost and where I could get one? I'd love to have the jet ski running, but after paying for the EMM repair I don't want to spend much more money.

  6. #6
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,549
    +1
    2,711
    Quote Originally Posted by UnityRacing View Post
    At rest after the ski has been sitting for a few hours, take the inside of the Schrader valve out and clamp the line to the rear of the valve. See if you can blow into the valve. You should not be able to. If you can then it sounds like the FPR is stuck open...
    First open the gas cap to release any trapped air pressure. Leave the gas cap cracked while you 'pressure test' the pressure regulator.

    For the described test it would be critical that the fuel hose be fully clamped shut as any air leakage would be misleading for diagnosis.

  7. #7
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,549
    +1
    2,711
    Quote Originally Posted by Carlin View Post
    ...
    We had a bad fuel pump once before and the mechanic said that the EMM was what ruined it, so we replaced the fuel pump and had the EMM repaired less than a year ago...
    Check the pin-40 in the large connector to the EMM. That is the Brown wire that controls the fuel pump. Sometimes that wire contact becomes damaged or burned, resulting in weak current flow and reduced voltage at the running fuel pump.

    Is there a warranty on the EMM repair?

    Was the replacement fuel pump new?

    Note that even a 'new' fuel pump still runs the risk of the pressure regulator falling out. A new fuel pump is probably an inventory item from back when Polaris stopped manufacture, so it could have been sitting for ten years or more before you got it.

    Once you figure out what is causing the current troubles, be sure to reinforce the pressure regulator inside the fuel pump, regardless of how old or new the particular fuel pump is.

  8. #8

    Join Date
    Jun 2015
    Posts
    15
    Thanks for the help K447. The fuel pump was new when it was replaced about a year ago and hasn't hardly been used becuase the EMM went out shortly after we replaced it. The EMM does have a one year warranty which I believe runs out in September.

    Do you agree that I should get another TPS?

  9. #9
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,549
    +1
    2,711
    Quote Originally Posted by Carlin View Post
    ... Do you agree that I should get another TPS?
    It is always worthwhile to have a spare TPS on hand. There is no workaround for a bad TPS and a failing TPS can create all sorts of weird symptoms.

    Installing a new TPS can show that the problem is NOT the old TPS, or it can prove the problem IS the old TPS.

    Do do not assume there I only one problem. Sometimes there are several things happening at the same time, creating difficulty in diagnosis.

  10. #10

    Join Date
    Jun 2015
    Posts
    15
    Do you know where I could buy a new TPS from and how much it might cost? Unfortunately I do not have time to work on it today, but I would like to browse later. If you could point me in the right direction it would be greatly appreciated.
    Thanks

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage 1200 TXi - first post and problem PLEASE HELP
    By husky9 in forum Polaris Open Discussion
    Replies: 217
    Last Post: 11-05-2018, 04:02 PM
  2. Polaris virage txi a lot of problem, please help
    By arqjorgelg in forum Polaris Open Discussion
    Replies: 15
    Last Post: 08-21-2012, 11:09 AM
  3. Genesis FFI Oil Problem- Please help
    By jmason2088 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-08-2006, 01:36 PM
  4. Polaris Virage Display Flashes. Please Help!!!!
    By Lambrosfl in forum Polaris Open Discussion
    Replies: 2
    Last Post: 10-19-2006, 08:45 AM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •