Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1

    Join Date
    May 2015
    Location
    Riverview, Fl
    Posts
    23

    Another Impeller Question

    I have a 2012 RXT-X with the following: 4" Kanaflex intake, FA removed, Riva free flow exhaust, R&D grate, Running the VTECH 8250 Tune. I just installed a Solas 15/20A and new wear ring. I am only turning 7700RPM at 68 MPH. Am I going to need to get a different prop to pick up 700RPM? I would hate to spend the money on another new prop. I was planning on putting that cash towards the lucky 13 cone.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,653
    +1
    508
    IMO 15/20 is too much prop for a X charger

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,020
    +1
    779
    Something is not correct and you should easily turn over 8000 rpm with a TRUE 15/20 and your mods.

    You have a stock 83mm venturi nozzle and adding a L13 is waste of money with your limited mods. Most people that have had success with the L13 are using 87mm nozzles and turning MUCH higher rpms. There are some turbo guys running the 83mm + L13 but are turning 9200-9300 rpm and 21-23 psi boost. If you add the L13 you will drop even more rpms.

    I would not be surprised to find that your 15/20 is something more…….

    Make sure you don't have a boost leak or IC leaking.

  4. +1 by:


  5. #4

    Join Date
    May 2015
    Location
    Riverview, Fl
    Posts
    23
    I have to agree! I read the modding guide and that is why I went with the 15/20. Is there something you would recommend? I guess I could go back to stock.

  6. #5
    formula29's Avatar
    Join Date
    Feb 2014
    Location
    Ormond Beach
    Posts
    139
    +1
    11
    just as a comparison for you, I have the same ski, no tune, I just tried a 15/20r and was turning 7,0850@72mph could your tune have gotten changed back to stock?

  7. #6

    Join Date
    Mar 2013
    Location
    Appleton, WI
    Posts
    590
    +1
    93
    Props don't always come pitched correctly and it doesn't take much to drop/increase RPM's.

    I'd pull the prop and put the stock on and see where your at. During that time I'd take your prop to a shop and have them check the pitch and adjust it from there. You'll want to get your Solas dialed in as it will perform much better than the stock impeller even if pitched correctly.

  8. #7

    Join Date
    May 2015
    Location
    Riverview, Fl
    Posts
    23
    I just reflashed it again to be sure. It came back successful. I will switch back to the stock prop and take it out this afternoon and test it out. Thanks everyone for your suggestions.

  9. #8

    Join Date
    May 2015
    Location
    Riverview, Fl
    Posts
    23
    Ok, I checked all the hoses. Everything is tight. I don't see any leaks. I put the stock impeller back in and now I am seeing 8060rpm at 68MPH. It will hit 69MPH and 8100 for a few seconds and drops back down. It is almost like the speed limit is still in place. I even tried the 8350 tune and still the same result. Is there something I am missing? I figured I should be able to push the stock prop higher than this. The accereration is there but it loses everything at the top end. Now I can beat my friends FZS out of the hole.

  10. #9
    formula29's Avatar
    Join Date
    Feb 2014
    Location
    Ormond Beach
    Posts
    139
    +1
    11
    What rpm's did it turn before you tried the solas? It would appear that your stock tune is still in place,

  11. #10

    Join Date
    May 2015
    Location
    Riverview, Fl
    Posts
    23
    The tune has changed, I notice the throttle response is different.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another Impeller question
    By chillindamost02 in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-26-2014, 09:18 AM
  2. Another gtx Question after impeller bearing replacement
    By Seafordguy in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-03-2014, 06:17 AM
  3. Another trailer question
    By Piney in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-17-2006, 06:15 PM
  4. another fogging question?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 11-10-2005, 05:58 PM
  5. Solas impeller question
    By Jeff C in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-03-2005, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •